1997 Chevy Blazer Starts when it wants

Tiny
RYAN SOUTH
  • MEMBER
  • 1997 CHEVROLET BLAZER
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 150,000 MILES
1997 Blazer 6 cyl 4.3L The problem is: When I go to start the motor sometimes it works perfectly starts right away-it is all tuned up: new plugs, wires, filter, rebuilt alternator, etc. BUT sometimes I will turn the key and nothing at all. It will not crank-no life at all. I have changed the starter 2 twice in the last 4 years since I bought it. I should have picked up then something else was wrong the second time I changed the starter. I listened to the mechanics and they always wanted to replace the starter. It also has a new battery and battery cables. I put it on a scanner and everything was good: battery, alternator, motor, EXCEPT they said the amperage draw when starting the motor from the starter was way to high. The starter is new (within the year) and I had this same problem with the original and the last one before this one. Could it be bad grounds? The cables from the battery are new and tight. Maybe a ground cable from the motor to the frame or something else? It runs perfectly except for this problem. Also the AC sometimes works and sometimes does not work-I don't know if this is related and caused from the same problem? I checked for a parasitic drain but the draw when everything was off was very low so I don't think this is the problem.
Do you
have the same problem?
Yes
No
Sunday, October 17th, 2010 AT 1:31 PM

5 Replies

Tiny
RASMATAZ
  • MEMBER
Hi Ryan South, Welcome to 2carpros and TY for the donation

When you turn key to run do you see all the idiot lites that normally comes before you crank the engine over-If not could be the ignition switch if so check and test the starter relay and transmission range switch
Was this
answer
helpful?
Yes
No
-1
Sunday, October 17th, 2010 AT 1:42 PM
Tiny
RYAN SOUTH
  • MEMBER
Hello Thank you for your reply. Yes, I see the idiot lights come on when the key is turned, everything seems normal except no cranking. Can you please tell me what the transmission range switch is and where it is and how to check it? I am not familiar with that switch or where it is. Also how would I check the ignition to make sure that was not the problem?
Thank you,
Ryan
Was this
answer
helpful?
Yes
No
Monday, October 18th, 2010 AT 8:15 AM
Tiny
RASMATAZ
  • MEMBER
Check and test the crank fuse no.20 10amp in the I/P fuse block if okay find the transmission range switch on the left side of the transmission unplug it check for power on the purple wire, while a helper hold key in cranking position -let me know
Was this
answer
helpful?
Yes
No
Monday, October 18th, 2010 AT 5:42 PM
Tiny
RYAN SOUTH
  • MEMBER
Hello,
Thank you again for the reply. I replaced the all fuses when I first was checking this problem but I will check it again as you recommended. Also when I scanned the vehicle before, there was a notice of something transmission related as a problem on the scanner-maybe it is that switch? But I will check this weekend the power going to the switch as you recommended and let you know.
Thanks for your help,
Ryan
Was this
answer
helpful?
Yes
No
Tuesday, October 19th, 2010 AT 1:03 PM
Tiny
RYAN SOUTH
  • MEMBER
Hello. Sorry for the delayed response. I checked the transmission range switch at the purple wire while someone was cranking the key-there was power there and no starting. I jumped the starter with a jumper cable directly to the starter and it cranked fine when I did this. Thanks.
Was this
answer
helpful?
Yes
No
Wednesday, December 8th, 2010 AT 12:43 AM

Please login or register to post a reply.

Recommended Guides