2004 Chevy Astro Wiper motor

Tiny
DSKINNER612
  • MEMBER
  • 2004 CHEVROLET ASTRO
  • 6 CYL
  • AWD
  • AUTOMATIC
  • 38,000 MILES
I have a 04 Astro van, the front wipers worked earlier this morning, I went to use again and nothing. The solvent works through the switch, but the wipers do not. I checked fuse, it looks fine. Would the switch be at fault or wiper motor. This is the front wiper motor.
Do you
have the same problem?
Yes
No
Monday, December 1st, 2008 AT 10:51 AM

3 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi:
It could be the switch or the motor. If it isn't working, turn the key on and the wipers. With a test light, check if there is power at the wiper motor. If there is, most likely it's the motor. If there is no power, the problem exist before the motor. Check for damage to the wiring harness near the fire wall. If none, you will need to check power at the switch. If you have an air bag, I recommend having the steering wheel removed by a trained technician.

Joe
Was this
answer
helpful?
Yes
No
Tuesday, December 2nd, 2008 AT 5:04 PM
Tiny
DSKINNER612
  • MEMBER
Thanks, I replaced the fuse to start even though it looked fine, then I ended up replacing the board, still no luck, I replaced the whole motor, still no luck. The only thing left is the switch. Its at the dealer, its a warranty issue.100$ deductable is better that 400 for a new switch. Thanks for Your reply. Dan
Was this
answer
helpful?
Yes
No
Tuesday, December 2nd, 2008 AT 5:30 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Dan, I'm glad it's a warranty issue. If you have any questions in the future, let us know.

Joe
Was this
answer
helpful?
Yes
No
Tuesday, December 2nd, 2008 AT 7:07 PM

Please login or register to post a reply.

Sponsored links