1999 Chevy Astro Engine run good at idle but doesnt pick-up

Tiny
GILBERT0618
  • MEMBER
  • 1999 CHEVROLET ASTRO
Engine Performance problem
1999 Chevy Astro 6 cyl Two Wheel Drive Automatic

Hi ! I have a chevrolet astro 1999 with a 4.3 liter engine, My problem start one day coming home from work, its a 30 miles drive, my van was working good every day then from one day to another, the engine woulnd pick-up speed ! I was going at a top speed of 25 miles per hour, I wasnt able to go more faster then that, the day after I try the van again I started the engine at idle the engine run very well, but when you press on the gaz pedal, its not responding well, the engine as a hard time to pick-up speed as if its not taking the gaz properly, either its air problem or electrical problem I dont know, I have change the gaz filter and the mass airflow sensor, I brought the van to a garage near my place and the dont know what is the problem ! On my way back I had to go up a hill to get to my home and the truck barely made it ! CAN YOU HELP ME !
Do you
have the same problem?
Yes
No
Wednesday, January 7th, 2009 AT 9:14 PM

4 Replies

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi:
If there is no check engine light on, my first guess would be the catylatic converter is plugged. Check that first. You will be looking for limited exhaust from the tail pipe, maybe a strange noise, rattle, whistle, hiss. Also, in the dark allow it to run. I have seen them actually glow red hot when they are plugged.

Let me know if this helps.

Joe
Was this
answer
helpful?
Yes
No
Thursday, January 8th, 2009 AT 8:34 PM
Tiny
GILBERT0618
  • MEMBER
Thanks! Jacobandnickolas for the reply ! Its true there is no check engine light open, you might be right about the catylatic converter, but I did have a similar problem like 2 month before with my other car, its a Kia Sephia Ls 2000 1.8 liter automatic and after brigning that car to 2 different garage, because the first garage didnt know what was the problem, I had to go to a canadian tire garage to finaly found that it was the catylatic converter that was finish Pluged ! But dont you find that weird that 2 vehicule from the same owner would have a catylatic problem nearly a the same time !Is it a fuel problem that cause that to pluged ! I always gaz at Shell (regular unleaded fuel). Anyway to come back to the chevy astro my problem was similar to the kia but the only thing that I find different its wheen I press on the gaz the engine doesnt run good but at idle its ok ! And with the kia the engine at idle was running good and when I was pressing on the gaz the engine was still running good but you could only feel the loss of power when I was driving other then that you coulnd tell the difference. Any way the repair for my kia came up to $850.00 parts and labor, then when it came to the astro van I figure out that it would cost me about $1000.00 so I store the van in my garage and whent to buy a new Dodge Caliber 2007, so its been 2 years since I store the van and now I want to put it back on the road, that why I post an ad on this site for help!
Was this
answer
helpful?
Yes
No
Friday, January 9th, 2009 AT 7:45 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
HHi:
Has the van been in storage for 2 years? If so, have you replaced the gas?
Was this
answer
helpful?
Yes
No
Friday, January 9th, 2009 AT 8:41 PM
Tiny
GILBERT0618
  • MEMBER
Yes ! It has been replace !
Was this
answer
helpful?
Yes
No
Friday, January 9th, 2009 AT 11:43 PM

Please login or register to post a reply.

Recommended Guides