Check engine Lights and codes

Tiny
RYAN IN MEXICO
  • MEMBER
  • 2008 DODGE DURANGO
  • 61,000 MILES
Hello from down south! I am currently living in Mexico. I have a vehicle down here at my place here. The climate is very hard on vehicles. However, the problem I have now is this: I have recently purchased a 2008 Dodge Durange 5.7L Hemi rear wheel drive truck.
There are some codes. The speedometer shows: 'Change Oil' (need to get this done), 'gas cap'. It reads that. There is also the check engine light. I put it on a scanner and the results were:
1. Small leak in the evaporacion system detected. (I already purchased a new gas cap-so that was not the problem the light did not go away). The printout also says there is a large leak in the evap/gas system somewhere.
2. (Different code) The module detects an error in reading the calculation for the air/combustion relation (I am trying to translate from spanish the codes to english).
Probably cause: oxigen sensor. It also says: reaction en H02$11 (Oxigen sensor hot Bank 1 Sensor 1). The truck has 4 oxigen sensors (I believe they are all identical?) So I would prefer to not change all of them as they are pricey if there is a way not to.

Can you please help me with these issues? The truck is all original and in very good shape. It needs maintenance and these 2 issues. Can you please help me with the above issues? I would obviously prefer to buy as few parts as possible. If you also have diagnostic tips to help solve the EVAP problem I would like to try that before taking it to a mechanic (many here have NO idea what they are doing when it comes to diagnosis).

Thank you! Ryan
Do you
have the same problem?
Yes
No
Monday, May 27th, 2013 AT 12:32 PM

6 Replies

Tiny
HMAC300
  • EXPERT
The O2 sensors are not identical, the firstsensor are but eh back two aren't Bank 1 sensor 1 is lh side first sensor. For the evap thing you have to do a smoke test to see where the problem is. It's special equipt, you might try a new evap purge solenoid orlook for a hose off cut etc. If you send the code numbers it is a lot easier for us to help.
Was this
answer
helpful?
Yes
No
Monday, May 27th, 2013 AT 12:46 PM
Tiny
RYAN IN MEXICO
  • MEMBER
Thank you! That is good to know the front and rear sensors are different. Also Bank 1 Sensor 1 is the Passenger or Drivers side (Left side I am not sure if from inside vehicle or looking at vehicle)? So you think the 'EVAP purge solenoid' or a hose might be the prob?

The actual codes are: P0456 and P0133

I hope this helps to narrow it down if we can with the codes.

Thank you!
Ryan
Was this
answer
helpful?
Yes
No
Monday, May 27th, 2013 AT 3:34 PM
Tiny
HMAC300
  • EXPERT
Code 133 could be a bad O2, and exaust leak or just eh circuit grounded or shorted out. Lh side is drivers side it cold also be from silicone or bad fuel in the system. 456 is a small leak in evap which cold be evap switch/solenoid or aplainold leak this has to be smoke tested which requires a special tool for that. The two pics i'm sending is one of the evap switch and other of solenoid. Have fun.
Was this
answer
helpful?
Yes
No
Monday, May 27th, 2013 AT 3:44 PM
Tiny
RYAN IN MEXICO
  • MEMBER
Thank you very much! Your help is greatly apprecited! I think I will try to change the solenoid first (it is only $30 USD or so here). Hopefully that is the problem as it is the cheapest, and easiest to get to and I can do that myself easily. If not guess it is switch or other issue (of course before changing the solenoid I will check all hoeses, etc.)
I will buy the drivers side O2 sensor and have that changed and hope that takes care of the check engine light.
Thanks again,
Ryan
Was this
answer
helpful?
Yes
No
Monday, May 27th, 2013 AT 4:30 PM
Tiny
RYAN IN MEXICO
  • MEMBER
Hello 2 Car Pros.

Thank you for your help and answers above. I recently took the truck in again to get it scanned to see if the codes were the same. These are the codes I got:

P1128
P0456 (same as what you explained above)
P0132

Since the last messages I did change the front drivers side O2 sensor (I previously had the P0133 code now it is changed to the above codes).

Can you please help me with the P1128 and P0132 codes? Are those the other O2 sensors?

Thanks for all your great help sorry to ask the same question over again with slightly different codes.

Thanks, Ryan
Was this
answer
helpful?
Yes
No
Tuesday, February 11th, 2014 AT 5:39 PM
Tiny
HMAC300
  • EXPERT
As this is a new question please repost the next time. 128 is a pcm not getting right temp look for low coolant, sensor wiring issue or pcm problem if coolant low pressure check for internal leaks like ahead gasket. 132 is a problem with the lh front o2 sensor or shorted wiring etc.
Was this
answer
helpful?
Yes
No
Wednesday, February 12th, 2014 AT 6:19 AM

Please login or register to post a reply.

Recommended Guides