Car dies after running for 5 minutes

  • 1 POST
  • 3.8L
  • 6 CYL
  • FWD
  • 130,000 MILES

Start engine and it idles fine for 6 minutes then runs rough and dies. It won't run again till it cools unless you floor it(wide open throttle). The car was recently smogged and was a-ok. Have replaced the crank position sensor and fuel pressure regulator, fuel injector o-rings, vacuum lines, and coolant temperature sensor and thermostat. Next up, I was going to replace the fuel pump and filter and found a hairline crack in mass airflow sensor. Actron Scan tool shows everything is is within tolerance and then it coughs and quits There are no trouble codes or even intermittent ones. I've been told it was flooding and that the mass airflow sensor was going, and also that stuff in the tank could be cutting off fuel flow. The car had been running fine it sputtered like it had run out of gas. When tank was filled it only took 10 gallons and the problem has been occurring ever since. I've even been told the ecm is going bad but it checks out okay it flashes 12. Any help would be appreciated

Do you
have the same problem?
Saturday, February 28th, 2015 AT 3:16 AM

1 Reply

  • 21,081 POSTS

A qualified tech would be able to isolate what is actually happening to the engine to cause it to dies. It's going to require a lot of testing and not wild guesses to get to the bottom of this. If I was to guess I would say it sounds like it's over fueling for some reason, The reason could be all kinds of different things like leaking fuel pressure regulator or injectors of even an inaccurate temp sensor reading too cold.

Was this
Saturday, February 28th, 2015 AT 5:08 AM

Please login or register to post a reply.

Recommended Guides