Stop it at a sign or light, then go to accelerate, it cuts off?

Tiny
FRESH7559
  • MEMBER
  • 2012 FORD FOCUS
  • 2.0L
  • 4 CYL
  • AUTOMATIC
  • 130,000 MILES
So, I drive around for work. After a few hours of driving. It'll start up fine, then when I slow down enough or stop at a sign or light, then go to accelerate, it cuts off. It's trying to stay on, and RPMs are going up and down but doesn't move at all then it just shuts off. I crank it up again let go of the key and it continues to try to crank for 5 seconds and then starts up again. It rides fine till I stop then it cuts off. If I don't slow down (ex: on highway) it won't cut off until I slow down or stop and go to accelerate. I could drive it if I didn't have to stop. But in Miami traffic is impossible. Please help me. I keep putting money into it. Just changed the O2 sensor. Engine light cut off. Then cuts on, and when it starts happening again. And it will disappear.
Do you
have the same problem?
Yes
No
Wednesday, November 16th, 2022 AT 12:41 PM

1 Reply

Tiny
KEN L
  • ADMIN
Okay, the check engine light is telling you there is a code present, lets run the codes to see what comes up. this guide can help:

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

and this guide can help as well because it sounds like you have a vacuum leak, or the throttle body needs to be serviced.

https://www.2carpros.com/articles/stall-at-idle

and

https://www.2carpros.com/articles/throttle-actuator-service

Use this guide when the engine is cold only.

https://www.2carpros.com/articles/how-to-use-an-engine-vacuum-gauge

Check out the images (below). Please let us know what happens.
Was this
answer
helpful?
Yes
No
Wednesday, November 16th, 2022 AT 1:06 PM

Please login or register to post a reply.

Sponsored links