2001 Cadillac SLS Service Engine Light

Tiny
JOHNLWEST2008
  • MEMBER
  • 2001 CADILLAC SLS
  • V8
  • 2WD
  • AUTOMATIC
  • 43,000 MILES
A couple of days ago I had to change the battery. At first I figured I had left a light on or something and just needed a jump. Well I got the jump and the went up to blockbuster down the street. After I turned the engine off I decided to try and start it. Well it was absolutely dead again! I got another jump and drover over to autozone and bought a new battery in which they charged me 140.00. Unbelievable! Well upon installing the battery we discovered that the positive metal connection the the cables screw into was broken from its insert. Thus no power.

However after turning the car back on, the Service engine light came on. Also the line that shows under the gear that the car is on, on the display panel, was no longer showing. In otherwords no indication as to which gear I was in besides the gear shifter itself.

Also it seems that the transmission was shifting just a little harder as well.

?
Do you
have the same problem?
Yes
No
Tuesday, October 14th, 2008 AT 4:28 PM

1 Reply

Tiny
RASMATAZ
  • MEMBER
Get Autozone to read out the OBD2 code/s from the computer its a free service atleast they owe you that for buying a battery.

Okay battery being disconnected-the computer has lost its programmed therefore need to relearn it thru cycles


http://www.2carpros.com/forum/automotive_pictures/12900_computer_relearn_with_symptoms_1.jpg

Was this
answer
helpful?
Yes
No
Tuesday, October 14th, 2008 AT 4:57 PM

Please login or register to post a reply.

Recommended Guides