1996 Cadillac SLS idles rough, no power while accelerating

Tiny
DUTY
  • MEMBER
  • 1996 CADILLAC SLS
  • V8
  • FWD
  • AUTOMATIC
  • 88,000 MILES
Help, need answers regarding this. Service engiine light on. Idle rough & no power under acceleration. Under powered driving down the road. Dont know if its a fouled plug, injector, sensor, or what. Cant drive to local parts to store to have computer scanned do to this condition. Any response would help. Car has 88,000 miles on it and have had no problems until now.
Do you
have the same problem?
Yes
No
Saturday, January 24th, 2009 AT 11:13 AM

2 Replies

Tiny
DOCFIXIT
  • EXPERT
Too many possibilities need scan for codes see if you can rent from parts house
Was this
answer
helpful?
Yes
No
Saturday, January 24th, 2009 AT 11:24 AM
Tiny
FACTORYJACK
  • EXPERT
With key on, push off and warmer at the same time, on your climate panel. Hold them until all lights come on, release them, and codes will start displaying. You are concerned with codes starting with'P'. See if you can get a code and repost. Sounds like possible misfires from plugs/wires, and/or coils. Possible plugged exhaust, low fuel pressure. A code may or may not point to a so-called smoking gun. P.S. If it is a dual zone climate system, and the drivers side has a knob, the use off and passenger warmer. Fan up will select items, and fan down will scroll. Scroll until you find pcm, Fan up then scroll until you find PCM codes and fan up again.
Was this
answer
helpful?
Yes
No
Friday, January 30th, 2009 AT 12:04 AM

Please login or register to post a reply.

Recommended Guides