1988 Cadillac El Dorado instrument cluster lights

Tiny
MYTROMPS&ME
  • MEMBER
  • 1988 CADILLAC EL DORADO
  • V8
  • FWD
  • AUTOMATIC
  • 10,300 MILES
The light on the cluster went out and I cannot find out why. I have checked the fuses and the fuse links and they are all working. The fuse links are all in one place under the hood but I cannot tell which is which. The manuel that I have does not tell me if the cluster has a fuse or a fuse linj. Can you help me with my problem?
I hope you can.
thank you very much for your attention and courtesies extended to my request
Best regards
Francisco A. Escobar, Sr.
Do you
have the same problem?
Yes
No
Sunday, September 20th, 2009 AT 5:46 PM

6 Replies

Tiny
MYTROMPS&ME
  • MEMBER
My msg. Ask if you can help me correct the problem with the lights on the instrument cluster.
Was this
answer
helpful?
Yes
No
Monday, September 21st, 2009 AT 1:09 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Are all of the lights out? Do any of the gauges work?
Was this
answer
helpful?
Yes
No
Monday, September 21st, 2009 AT 1:37 PM
Tiny
MYTROMPS&ME
  • MEMBER
Yesterday I answered the question which you asked. Did you get my answer? I have no indication on the instrument cluster so the gauges don't show up. Hope you can help me thank you very much for your time
regards

Francisco
ps. I have taken apart under the dash board and it is impossible to trace the cables. There are 4 cable ends that appear not in use, i.E. Maybe other options.

Updated 9/22/09
thank you for your response. None of the llights work, i.E, the whole cluster is blank(no lights). The head lights, interior, and directional all work. You ask if the gauges work, there is no lights to tell me if they work.
Without lightds on the cluster I cannot see the gas odometer. Etc. The radio light works. I hope I have provided enough info. Please let me know if you need more info.
Again thank you for your help, it's encouraging.
Regards
Francisco
Was this
answer
helpful?
Yes
No
Tuesday, September 22nd, 2009 AT 12:18 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
Have you checked under the dash for disconnected wires / connectors. If so and they are all attached, chances are the insturment cluster is bad.
Was this
answer
helpful?
Yes
No
Tuesday, September 22nd, 2009 AT 1:24 PM
Tiny
MYTROMPS&ME
  • MEMBER
Thank you for your reply. I have no way of checking connectors I was hoping to find where one connector went since it was different from the others but ai can't where it goes every thing, i.E, connectors wiring and bound harrness are too inter tangeled to be able to tell where what goes where. Do you by chance have a way of telling me how power gets to the cluster, or a picture of what the cluster looks like from the back?
Again thank you very much for your help I have no idea of determining if the cluster is bad.
Regards
Francisco A. Escobar, Sr.
Was this
answer
helpful?
Yes
No
Tuesday, September 22nd, 2009 AT 2:20 PM
Tiny
JACOBANDNICKOLAS
  • EXPERT
I don't have a wiring schematic that I can cut and paste a schematic.
Was this
answer
helpful?
Yes
No
Tuesday, September 22nd, 2009 AT 3:48 PM

Please login or register to post a reply.

Recommended Guides