1993 Cadillac Deville Hey

Tiny
MIKE2009
  • MEMBER
  • 1993 CADILLAC DEVILLE
  • V8
  • FWD
  • AUTOMATIC
  • 102,790 MILES
Hi everyone I have a 1993 cadillac deville 4.9L three months ago I had the transmission rebuilt and I fiinally fixed the misfire I had by changing all the spark plugs with ac delcos and a couple of wires were bad and that fixed the misfire I had on acceleration but now I have a problem at highway speeds only at 60mph and up when I let off the gas the car kicks everytime at that speed only when letting of the gas pedal what could the problem be any help could be appreciated thank you!
Do you
have the same problem?
Yes
No
Sunday, December 13th, 2009 AT 11:31 AM

6 Replies

Tiny
BLACKOP555
  • EXPERT
Please define what you mean by kick.

What else have you noticed happens when this happens.

Whats it feel like, whats it sound like? Wheres it seem to be coming from
Was this
answer
helpful?
Yes
No
Sunday, December 13th, 2009 AT 7:13 PM
Tiny
MIKE2009
  • MEMBER
I mean by kick when I left off the gas at highway speeds you feel like a bump either from the trans or engine but no noise or anything that's all I feel
Was this
answer
helpful?
Yes
No
Sunday, December 13th, 2009 AT 8:38 PM
Tiny
BLACKOP555
  • EXPERT
Kinda like if you were to have the brakes on and let off the gas but hold the brakes lightly. Kinda like the vehicle is decelerating too fast?

Check the fluid level first before you drive it agian to make sure you dont cause more damage if there is a issue with the transmission.

Does it jerk or is it smooth. Just that sudden decel feeling?
Was this
answer
helpful?
Yes
No
Sunday, December 13th, 2009 AT 8:54 PM
Tiny
MIKE2009
  • MEMBER
The Car jerks while cruising nd bogs own when I give I a lil more gas but the car really kicks when I keep tapping the gas a lil hard
Was this
answer
helpful?
Yes
No
Monday, December 14th, 2009 AT 6:23 PM
Tiny
BLACKOP555
  • EXPERT
Have the vehicle quickly scanned up by autozone and see if a code is hiding. Did you ever check the transmission fluid level? This all started after you changed plugs and wires? Make sure you ddint acidently bump a sensor or damage a wiring harness where you were working.

Also were the caps set properly on the plugs?

Hows car perform under heavy acceleration?
Was this
answer
helpful?
Yes
No
Monday, December 14th, 2009 AT 9:27 PM
Tiny
MIKE2009
  • MEMBER
The Transmission fluid is full and bright red there are no codes I check it automatically through the climate control because my car is a 93 and autozone only does 96 cars and newer but there are no code and the car runs great under heavy acceleration and this problem has been like this since the transmission was rebuilt 3 months ago the car had a bad misfire the spark plugs were fouled and the wires were bad so replaced all that the car doesn't misfire anymore just that little kick under light acceleration and a little sluggish could it be the tv cable?
Was this
answer
helpful?
Yes
No
Tuesday, December 15th, 2009 AT 7:39 AM

Please login or register to post a reply.

Recommended Guides