1992 Cadillac Deville limp mode.

Tiny
CLU
  • MEMBER
  • 1992 CADILLAC DEVILLE
Computer problem
1992 Cadillac Deville V8 Front Wheel Drive Automatic

HOW DO I TAKE MY CAR OFF OF "LIMP MODE"? I TRIED UNPLUGIN POS. CABLE DIDNT RESET. WOULD ME REPLACING MY (ECM) ENG. CON. COMPUTER SOLVE MY PROB.
Do you
have the same problem?
Yes
No
Tuesday, May 26th, 2009 AT 5:27 PM

6 Replies

Tiny
FACTORYJACK
  • EXPERT
I don't believe 92 has a limp home mode. What are the symptoms you are corecting, and have you made any repairs?
Was this
answer
helpful?
Yes
No
Tuesday, May 26th, 2009 AT 9:08 PM
Tiny
CLU
  • MEMBER
WELL YOU KNOW "LIMP MODE " MAKES MAKE THE THE ENGINE AND TRANS. NOT FUNCTION CORRECTLY.I NEEDED A SWITCH. REPLACED THE SWITCH AND WAS TOLD BY A TECH THAT I NEEDED MY COMP RESET AND HE STATED THAT THE IT WAS IN "LIMP MODE". TRIED DIAG. AT A LOCAL SHOP DIAG MACH WOULDNT COMMUNICIATE WITH COMPUTER SO I WAS TOLD BY THIS TECH AT LOCAL SHOP TO REPLACE ENGINE CONTROL COMPUTER BEFORE HE COULD PERFORM DIAG. WOULD MY PROBLEMS BE SOLVED IF I REPLACE ECC?
Was this
answer
helpful?
Yes
No
Wednesday, May 27th, 2009 AT 12:26 AM
Tiny
FACTORYJACK
  • EXPERT
Replacing the ecm w/out proper diag would be a shot from the hip at this point. Does the engine start and run, and does the check engine light work? By the check engine working, I mean does it come on with key on, does it stay on when/if running? If you turn the key on, and press the 'off' button and the 'warmer(red)' button on the climate panel together, you will display codes at the fuel data center. E.0.0 will be ecm codes, F.0.0 are body codes. What are the codes displayed? It could be the machine that is not communicating with the ecm, you could have a poor ground, etc. Try this onboard feature and see if any codes display.
Was this
answer
helpful?
Yes
No
Wednesday, May 27th, 2009 AT 8:47 PM
Tiny
CLU
  • MEMBER
THE CAR STARTS AND RUNS FINE. IT TAKES OFF REALLY SLOW BUT ONCE IT GAIN SPEED IT RUN GOOD. THE ENGINE LIGHT STAYS ON MY HEATER STAYS ON IT WONT GO OFF. THE GAS GAUGE WONT DISPLAY.I REPLACED THE ECM AND I STILL HAVE THE SAME PROB.I HAVENT TOOK IT BACK IN TO DIAGNOSE YET.I WILL STILL TRY THAT FEATURE U MENTIONED
Was this
answer
helpful?
Yes
No
Thursday, May 28th, 2009 AT 9:25 PM
Tiny
CLU
  • MEMBER
I TRIED THE ON BOARD FEATURE. IT DIDNT WORK. THE FUEL DISPLAYS A "C" AT ALL TIMES AND THE CLIMATE CONTROL DOES ALSO. THE SERVICE ENG LIGH COME ON WHEN I TURN KEY. GOES OFF WHEN I START BUT LIKE 10 SECONDS LATER I COMES BACK ON.
Was this
answer
helpful?
Yes
No
Thursday, May 28th, 2009 AT 9:34 PM
Tiny
FACTORYJACK
  • EXPERT
You could have a communication fault in one of the other items, like the fuel data center, and possibly the bcm. It would prevent display of codes through the onboard. If you can locate the diagnostic connector under the center dash(there is an access panel in the lower insulator), you can jumper pins A and B. Turn the key on, and the engine light will flash codes in a flash-pause-flash routine. So for example a flash-flash pause flash-flash-flash would indicate 23. You should flash a code 12(flash pause flash-flash) at the beginning and end of the display. These are diagnostics indicator codes. Try and extract the ecm codes and that may lead to whats causing the running concern.
Was this
answer
helpful?
Yes
No
Friday, May 29th, 2009 AT 9:50 PM

Please login or register to post a reply.

Recommended Guides