2003 Cadillac CTS Engine Stalls

Tiny
LDY MAC
  • MEMBER
  • 2003 CADILLAC CTS
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 84,000 MILES
Engine stalls while driving. Towed off highway and purchased new battery (177.00) from dealer. Installed battery started right up drove about three blocks and car went dead again. No dash lights (warning) come on. No clue what to do or look for. Dash information shows battery volts "good" at 14.5 volts. Please Help! Will try any & all suggestions.
Do you
have the same problem?
Yes
No
Saturday, May 10th, 2008 AT 11:11 AM

6 Replies

Tiny
JACK42
  • MEMBER
Is the engine cutting out or the electrical shutting down? Either way the PCM may have stored a code to help us start this diagnosis, have it scanned to see. Did they test the charging system to see if it was ok?
Was this
answer
helpful?
Yes
No
-1
Sunday, May 11th, 2008 AT 9:07 AM
Tiny
LDY MAC
  • MEMBER
I had a diagnostic at checker auto, I was told all looked good on the meter reading. The car will start and drive and then about three (or less) blocks the volts drop to 12 and then everything shuts down. I wait about ten min. Unscrew the black cable from the battery attach it back and the car starts right back.I'm getting it towed to the dealer in the morning if I can't figure it out today. Thank you for your response. The diagnostic was done under the hood and under the driver side dash. Some plug under there.
Was this
answer
helpful?
Yes
No
Sunday, May 11th, 2008 AT 3:28 PM
Tiny
JACK42
  • MEMBER
There must not have been any codes in the PCM. This sounds like possibly a bad relay or ground somewhere, might even be a bad alternator
Was this
answer
helpful?
Yes
No
Monday, May 12th, 2008 AT 7:46 AM
Tiny
LDY MAC
  • MEMBER
Thank you for your response. I had the car towed this morning to the dealership. I will let you know what the outcome is when I hear from the technician.
Thanks again.
Was this
answer
helpful?
Yes
No
-1
Monday, May 12th, 2008 AT 11:27 AM
Tiny
LDY MAC
  • MEMBER
I spoke to the dealership, they have told me that they have found an error code that deals with the crank shift sensor. No clue what code that is since no codes came up over the weekend when I had the diagnostic conducted but, I'll have to go with it and pay $350.00 for the repairs. Does this sound like it could be causing the engine stall issues?
Was this
answer
helpful?
Yes
No
+1
Monday, May 12th, 2008 AT 4:21 PM
Tiny
BUZZSAW
  • MEMBER
Yes crank shaft position sensor
Was this
answer
helpful?
Yes
No
+2
Tuesday, May 13th, 2008 AT 10:57 AM

Please login or register to post a reply.

Recommended Guides