1998 Buick Regal Turn signals kill engine

Tiny
VICLYNN39
  • MEMBER
  • 1998 BUICK REGAL
Electrical problem
1998 Buick Regal V6 Front Wheel Drive Automatic 116000 miles

When I use either turn signal, sometimes it kills the engine. Other times all the lights on the dash come on and the gauges go crazy.
Then sometimes they work just fine. I never know when I will have the problem. I have had the signal lever switch replaced and it did not solve the problem. Now they say it could be the ignition switch but a few weeks ago my heater stopped working. How can that be connected to the ignition switch?
Has anyone else had this problem and had it successfully repaired? I'M SCARED TO DRIVE MY CAR!
Do you
have the same problem?
Yes
No
Monday, February 16th, 2009 AT 7:26 PM

6 Replies

Tiny
MASTERTECHTIM
  • MEMBER
Its possible to be related to the ignition switch. When its acting crazy try cyclind the ignition key and see if that helps. The inside of the ignition switches get charred from constant arcing and cause wierd electrical problems
Was this
answer
helpful?
Yes
No
Monday, February 16th, 2009 AT 7:29 PM
Tiny
RWB1
  • MEMBER
I am having the same problem. Sometimes my car wont start. If I turn on the turn signal everything goes black.
They tell me its the VATS system and I need a new ignition and key or to bypass it completely by soldering in a matching resistor bypassing the resistor key altogether. Not sure what to do
Was this
answer
helpful?
Yes
No
Tuesday, February 17th, 2009 AT 6:40 PM
Tiny
VICLYNN39
  • MEMBER
I had new ignition switch installed. Seems to have fixed the problem and I did not have to get a new ignition key. It's only been two days so I still cringe when I turn my signal lights on.
Heater still is not working.
Was this
answer
helpful?
Yes
No
Sunday, February 22nd, 2009 AT 1:05 PM
Tiny
MIKIMASTER
  • MEMBER
I have identical problem w Buick 2004. It can be very scary. Why the mfg does not run recall?
Let me know if the problem has been resolved, please.
Homegalaxy@gmail. Com
Was this
answer
helpful?
Yes
No
Monday, February 23rd, 2009 AT 10:44 PM
Tiny
VICLYNN39
  • MEMBER
Hello. Just letting you know that replacing the ignition switch seems to have solved my problem. Everything is working fine now - well except for the heater. I can always bundle up to stay warm.I'm just glad I can actually turn my signal lights on without worrying about killing my engine. Since the problem would not happen everytime I used my signals, it was very frustrating trying to make the mechanics understand how serious this problem was. I had to ASK the dealership to install a new switch, which was $300 parts and labor. They would not tell me that this WAS the problem. Only that it WAS POSSIBLE. I guess so they would not have to guarantee it. Anyway after spending $1000 - $700 of which was wasted (signal lever switch, alternator, and battery)- I think I am good to go!

Buick should have a recall concerning this problem.
Was this
answer
helpful?
Yes
No
Thursday, February 26th, 2009 AT 8:10 PM
Tiny
ZACKMAN
  • MEMBER
Your original post only stated that your heater quit working. Is the blower motor working at all? Please elaborate so I help diagnose.
Was this
answer
helpful?
Yes
No
Saturday, February 28th, 2009 AT 12:09 AM

Please login or register to post a reply.

Recommended Guides