Car stumped garages help!

Tiny
CARMENNL
  • MEMBER
  • BUICK CENTURY
97 buick century 3.1 automatic under 170,000 miles. Car stumped garages. It want start it sounds like it should turn over but it dont and no one can figure it out. Can you lead me in the right direction. They have checked the wires, fuses, and computer. Still nothing says im not getting power to enjectors. But I never got a check engine light that would indicate a problem. I have had a cat converter. Starter. Battery. And a feul pump put in prior to this. Happening. Can you help me please thanks in advance carmen
Do you
have the same problem?
Yes
No
Thursday, June 21st, 2007 AT 8:49 PM

12 Replies

Tiny
JACK42
  • MEMBER
In the underhood electrical center is a 15 amp fuse-F/INJ, test it for power in and out with a test light. That feeds power to the injectors, they are grounded by the PCM to make them work. Does the car have spark? Might be looking at a cam or crank angle sensor
Was this
answer
helpful?
Yes
No
Friday, June 22nd, 2007 AT 8:03 AM
Tiny
CARMENNL
  • MEMBER
Im told the car is not getting a spark. They say they have checked the sensor and the cam and the fuse is fine too. So now which way do I turn. Help me. Thank you in advance carmen
Was this
answer
helpful?
Yes
No
Friday, June 22nd, 2007 AT 8:54 AM
Tiny
JACK42
  • MEMBER
If the cam and crank sensors are ok, then you might be looking at an ignition module
Was this
answer
helpful?
Yes
No
Friday, June 22nd, 2007 AT 5:35 PM
Tiny
CARMENNL
  • MEMBER
Sorry I hadnt been in in a while to give updade.
Car is at the buick dealership and there im told this.
Im told today that he had ignition modular at home he put it in the car but it did not work. Charged 379.00 he also told me that he put in and emc the computer it too will not keep a spark charged 750.00 and it still dont work so now he says hes asking questions to general motors they have had my car for at least 2 weeks man I do tell you this something is wrong here other than these charges.
Was this
answer
helpful?
Yes
No
Friday, July 13th, 2007 AT 10:02 AM
Tiny
JACK42
  • MEMBER
What about the cam and crank angle sensors?
Was this
answer
helpful?
Yes
No
Friday, July 13th, 2007 AT 12:53 PM
Tiny
CARMENNL
  • MEMBER
I was told by the 2 garages that the sensors were good. But at the dealership I was told the 2 crank sensors were not communicating so the crank sensors were replaced. But the car still didnt start
Was this
answer
helpful?
Yes
No
Friday, July 13th, 2007 AT 3:25 PM
Tiny
JACK42
  • MEMBER
Sounds like some pin-to-pin wiring checks are in order to be sure that there isnt any damaged wiring from the sensors to the PCM.
Was this
answer
helpful?
Yes
No
Saturday, July 14th, 2007 AT 7:51 AM
Tiny
CARMENNL
  • MEMBER
With what you just said. One of the garages asked the dealership for a diagram of the cars wireing and was told they dont gelp with that. So this is why it went to the dealership. I too understand its a wireing problem just not sure which way to too start looking. But the dealer ship has had my car for 2 weeks. And hasnt come up with the right problem yet
Was this
answer
helpful?
Yes
No
Saturday, July 14th, 2007 AT 11:20 AM
Tiny
JACK42
  • MEMBER
At the bottom of our main forum page is a link "repair manuals" it goes to Mitchell-On-Demand. Same software shops use, has the entire wiring diagram for your can and it is printable
Was this
answer
helpful?
Yes
No
Sunday, July 15th, 2007 AT 7:56 AM
Tiny
CARMENNL
  • MEMBER
I must say thank you for your help in this. Car problem even though the car is at the dealership and you gave me pointers towards the problem. After all the cams the sensors and the computer was fine the sensors were changed. And a new computer was replaced and they did not start my car. Yet the price was added.1109.00and the car did not start. I told them what you said about the pin to pin problem on thursday 26 july. He told me that he was still getting help from the dealership and general motors on the problem I told him " im told it was a pin to pin problem some where in the car" he asked me: who is telling you this?" I replied 2 car pros. So he then says he will temm the machanic. I left the building. The next week on tuesday I called the dealership and asked bout the car. He said it was ready . Really? Yes was ready on saturday. I asked what was the problem. Im told it was a wiring problem in the harness a wire in the middle had gone bad. Lol just now not even 5 minutes ago I call them the dealership left a message he returns the call not 2 minutes later. Im told I had the wrong computer in my car thats why they were not getting a spark to the spark plugs if not the wrong computer the wrong modular 3.1 and a 3.8 on the engine it says 3.1 on the engine block but I had no problem all these years. Tell me what you think is happening. Thank you carmen
Was this
answer
helpful?
Yes
No
Monday, August 6th, 2007 AT 12:48 PM
Tiny
JACK42
  • MEMBER
Sounds like they threw parts at it instead of diagnosing it.I personally dont see how they could have the wrong PCM in the car, your car wasnt even offered with a 3.8l engine. Demand your money back for the PCM. Last but not least. Find a new mechanic
Was this
answer
helpful?
Yes
No
Monday, August 6th, 2007 AT 3:15 PM
Tiny
CARMENNL
  • MEMBER
Car is ready but im told not not only did I have the wrong computer in my car but now the reason is the problem with the wiring burning out it killed my computer. Wire in harnest shorted my computer. They said they sent in for a computer one comes back in it was the wrong one. Because out of the 10 years the computer has been made 10 times so the GM part number was not working for my computer and im not sure it was changed. I asked for the core he goes out of the room for bout 5 minutes comes back core gone and I would have to pay for the core charge if I wanted it. So im told to pay for the charges. How can I tell if I have a new computer installed? And why would some one change the computer. Reguardless of the makers number and the vin number it was a working computer in my car nothing was wrong with it until the supervisor said so. Not the machanic who was over the project of getting my car to start.I was told it was the wiring. But I had the wrong computer so it was changed, thank you carmen
Was this
answer
helpful?
Yes
No
Wednesday, August 15th, 2007 AT 6:53 AM

Please login or register to post a reply.

Recommended Guides