2000 Buick Century Overheated - now have very lil power

Tiny
FIREHAWK475
  • MEMBER
  • 2000 BUICK CENTURY
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 135,000 MILES
It overheated (guage creeped up to close to the red line then bounced up and down around it for a few minutes before finally hitting the max line and turning on the temp light - pulled off and let it cool. Once cooled down I started the car back up

Started right up temp guage was back to normal. Car engine sputtered and ran rough for a second then stalled.

Restarted same thing happened but didnt stall. Instead the "Trac OFF" light came on as well as the oil change light.

Restarted again and again idle was good for 10 seconds - then rough idle and the "Track Off" light turned on. Decided to drive anyways.

Trying to accellerate and the car was just a slug. No real power. Took half a mile to get to speed. Can't hold speed up hills. Engine is not reving high at all. Sounds like an exhaust leak but from the engine compartment.

Any help?
Do you
have the same problem?
Yes
No
Tuesday, November 18th, 2008 AT 12:02 PM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
Hi:
Based on your description, it sounds like there may have been some damage to one of the cylender heads as a result of the temp. If you open the hood, can you tell where the sound is coming from? My guess is that it's coming from an exhaust manifold. If the car is still running poorly, I recommend having a compression test to see if there is a head gasket or warped head problem.

Let me know what you find.

Joe
Was this
answer
helpful?
Yes
No
Wednesday, November 19th, 2008 AT 10:51 PM

Please login or register to post a reply.

Recommended Guides