ABS, CHECK ENGINE AND TRAC OFF LIGHT

2000 Buick Century

Tiny

Lingy07

December, 24, 2009 AT 1:10 PM

Brakes problem
2000 Buick Century 6 cyl Front Wheel Drive Automatic 86,370 miles

In the past couple of days I notice a buzzing noise and the check engine, abs, and no trac lights come on. I still have breaks everything seems normal. The lights seem to go away if the car is off overnight but came back on after driveing for 20 mins or so. It has been wet and slushy where I live so I don't know if a cable or sensor is getting wet( they have come on before in the snow). I read on these forms that there is a defect for 2001 Century's with a similar problem where it is both front Wheel speed harnesses. I was just wondering if this would apply to the 2000 model also and if anybody has had teh same propblem and fixes.

1 Answer

Tiny

jaybin82

December, 24, 2009 AT 1:35 PM

Bad hub. Your abs and traction control is ran through a wire harness on the bottom of the hub. The abs and traction control needs a constant current. When the wheel bearing seal in the hub breaks it throughs greese on the sensors. Do you hear like a " whine" or kind of a grinding noise when it does it? When the car and the warning lights are on, back probe the wire harness for the abs/traction control. It will tell you which one is bad I cant remeber what the resistance should be. I also heard if you take one harness off at a time and put a jumper wire on it and the light goes off, thats your bad hub. Hope it helps.

Please login or register to post a reply.

Wonder How Traction Control Works?
How to gather codes Ford Explorer
How to read codes Chevrolet Blazer
Read Codes Like a Pro
Code Read Retrieval/Clear - Dodge Stratus
Code Read Retrieval/Clear Chevrolet Camaro
Brake Light Bulb Replacement