2000 Buick Century

Tiny
ANDREARS
  • MEMBER
  • 2000 BUICK CENTURY
Electrical problem
2000 Buick Century 6 cyl Front Wheel Drive Automatic

My car is no longer starting but the upper blower is always working: even with no key in the contact.
The battery is OK and the fuse for the upper blowerr have been removed to advoid discharging it
Do you
have the same problem?
Yes
No
Monday, November 1st, 2010 AT 5:35 PM

3 Replies

Tiny
JDL
  • EXPERT
Make sure the battery has a full charge, use a digital multimeter across battery posts, everything turned off. The generic spec for a full charge is 12.6 volts. Also, engine cranking, the reading shouldn't drop below 10 volts, usually, at the battery posts. Are you saying it cranks good, but, won't start, or it won't even crank? Sometimes if battery voltage is lost, it may go into theft lock? Security system.
Was this
answer
helpful?
Yes
No
Monday, November 1st, 2010 AT 6:26 PM
Tiny
ANDREARS
  • MEMBER
In fact, it won't even crank. Tomorrow morning, I would check the battery with a multimeter.
Thank you for the support !
Was this
answer
helpful?
Yes
No
Monday, November 1st, 2010 AT 7:00 PM
Tiny
WRENCHTECH
  • EXPERT
I'm not sure if you have battery issues now due to the blower problems but to resolve the blower problems I would replace the blower motor resister which incorporates the blower relay and likely the reason the blower won't shut off. It's located next to the blower motor under the dash on the passenger side.


http://www.2carpros.com/forum/automotive_pictures/561653_Blower_motor_resister_00_Century_1.jpg

Was this
answer
helpful?
Yes
No
Thursday, November 4th, 2010 AT 4:43 AM

Please login or register to post a reply.

Recommended Guides