O2 SENSORS

1994 Buick Century

Tiny

jjblue

January, 20, 2008 AT 5:47 PM

Engine problem
1994 Buick Century 6 cyl Front Wheel Drive Automatic 145, 00 miles

problem was with my car with stalling all the time and poor gas consumption. (3800) 02 sensor showed up on scanner w one-wire O2 sensor like it was called for-still stalled and check engine light was still on. Put in 4-wire sensor and it runs beautiful! (Front 02 sensor). What's up with that? I thought they didn't use them till 96-maybe my car is newer than I thoought?

FOUND 3464 RELATED QUESTIONS

4 Answers

Tiny

BMRFIXIT

January, 25, 2008 AT 5:20 PM

How did you plug 4 wire sensor in one wire plug?

Tiny

jjblue

January, 26, 2008 AT 6:29 PM

That's a good question : ) : I didn't do it-I will ask him. I t was running great for 2 weeks, but now I have another problem with it skipping (bucking) and serging forward. After the 02 sensor was put in-it ran beautiful-no stalling and no gas guzzling. I'm almost ready to give up. I just can't buy another car unlessI get this one right to sell it. Thank you!

Tiny

jjblue

January, 26, 2008 AT 6:31 PM

Also, I was told that this is a california car so their emmisions stuff is different?

Tiny

BMRFIXIT

January, 26, 2008 AT 7:44 PM

What about the MASS air flow sensor and the coolant sensor
try to unplug that o2 sensor and try it

Please login or register to post a reply.

Oxygen Sensor Replacement Dodge Stratus
Oxygen Sensor Replacement Honda Civic 1996-20
Fail Your Smog Test? Fix it Fast
Code Read Retrieval/Clear Scion XD
How to gather codes Ford Explorer
Code Read Retrieval/Clear Mercedes Benz