Brakes don't work after hours of not using

Tiny
GATKLIDDEN
  • MEMBER
  • 2011 CHEVROLET CAMARO
  • V6
  • RWD
  • AUTOMATIC
  • 40,000 MILES
When I haven't used my car for a couple hours (overnight, 8 hour work day) and I try using my brakes they don't work. I can push the pedal all the way to the floor and it will slowly stop. I try to pump a few times before I go and that normally seems to help. By the time I am out of a parking lot they work fine and no problems at all when driving around. I have had a few conversations with co workers and friends that have mentioned the brake line or master cylinder. I plan on taking it in but also wondered if anyone knows the approximate costs for these repairs or if these are even good explanations for my problem.
Do you
have the same problem?
Yes
No
Wednesday, July 30th, 2014 AT 8:30 AM

2 Replies

Tiny
HMAC300
  • EXPERT
Actually with 40k it may be time for new brake pads at least in front. Check how much fluid is in master as it may be low partially causing your problem. But have a pro check them right away
Was this
answer
helpful?
Yes
No
Wednesday, July 30th, 2014 AT 1:00 PM
Tiny
JIS001
  • EXPERT
The problem you are describing seems more like a problem with the power brake booster vacuum pump or the solenoid. Check vacuum pump while pumping the brakes. The vacuum pump should come on. If it does not replace the pump. If it is ok replace the hose with solenoid. Attached several images so you can see what it looks like. Good luck and keep us posted.
Was this
answer
helpful?
Yes
No
Wednesday, July 30th, 2014 AT 2:49 PM

Please login or register to post a reply.

Sponsored links