Brake vibrating when idling in gear

Tiny
BAKHTIAR DUSKY
  • MEMBER
  • 2011 KIA
  • 3.5L
  • V6
  • 2WD
  • AUTOMATIC
  • 54,059,294 MILES
Hello guys, my car has a problem with vibrating on braking when on idle in drive and when the car is stopped. However, when is in neutral it works fine. Thanks
Do you
have the same problem?
Yes
No
Monday, October 31st, 2016 AT 10:50 PM

15 Replies

Tiny
SATURNTECH9
  • EXPERT
Sounds like you have a worn engine and or transmission mounts. What is the actual mileage on the car?
Was this
answer
helpful?
Yes
No
Monday, October 31st, 2016 AT 11:15 PM
Tiny
BAKHTIAR DUSKY
  • MEMBER
Almost 54,680 miles. The vehicle does not make any noise it just vibrates when I stand still at traffic light etc. But when I switch to neutral it goes away.
Was this
answer
helpful?
Yes
No
Monday, October 31st, 2016 AT 11:31 PM
Tiny
KEN
  • ADMIN
It definitely sounds like and engine mount that has collapsed. Raise the car and use a flashlight to check the engine and transmission mounts, you should be able to see one that is torn or worn down.

Please let us know what you find so it will help others.

Best, Ken
Was this
answer
helpful?
Yes
No
Tuesday, November 1st, 2016 AT 9:41 AM
Tiny
BAKHTIAR DUSKY
  • MEMBER
Thanks for the replay guys, but may I know what is mounts?
Was this
answer
helpful?
Yes
No
Tuesday, November 1st, 2016 AT 9:55 AM
Tiny
KEN
  • ADMIN
These are the parts that have a rubber insulator that support the engine and transmission. When the engine is running it vibrates the engine and transmission mounts shield the car from this vibration.
Was this
answer
helpful?
Yes
No
Tuesday, November 1st, 2016 AT 10:31 AM
Tiny
BAKHTIAR DUSKY
  • MEMBER
Oh I see thanks, and it is critical to replace it immediately when it happen? Or does will it make a serious damage?
Was this
answer
helpful?
Yes
No
Tuesday, November 1st, 2016 AT 10:33 AM
Tiny
KEN
  • ADMIN
It can cause damage if let go too long, it depends on how bad they are worn and broken. Inspection is required.

Best, Ken
Was this
answer
helpful?
Yes
No
Tuesday, November 1st, 2016 AT 10:52 AM
Tiny
BAKHTIAR DUSKY
  • MEMBER
Okay man, thanks I will check it and post the results.
Was this
answer
helpful?
Yes
No
Tuesday, November 1st, 2016 AT 11:05 AM
Tiny
SATURNTECH9
  • EXPERT
Yes, eventually they will tear free and can damage other mounts etc over time.
Was this
answer
helpful?
Yes
No
Tuesday, November 1st, 2016 AT 12:28 PM
Tiny
BAKHTIAR DUSKY
  • MEMBER
Hey guys it was due to Transmission mount but they said we dont have the genuine one and I didnot want them to put the none genuine one. So I will have to wait till they get the genuine one. But I dont know if its bad to let it till it get here I mean its not as bad as if it was the Engine Mounts right?
Was this
answer
helpful?
Yes
No
Saturday, November 5th, 2016 AT 2:27 PM
Tiny
SATURNTECH9
  • EXPERT
I have used aftermarket mounts before and haven't had any issues verus factory ones.
Was this
answer
helpful?
Yes
No
Saturday, November 5th, 2016 AT 5:05 PM
Tiny
BAKHTIAR DUSKY
  • MEMBER
Oh I see so its not that important to install the Genuine one?
Was this
answer
helpful?
Yes
No
Sunday, November 6th, 2016 AT 1:38 AM
Tiny
SATURNTECH9
  • EXPERT
No it's not.
Was this
answer
helpful?
Yes
No
Sunday, November 6th, 2016 AT 1:56 AM
Tiny
BAKHTIAR DUSKY
  • MEMBER
Ok thanks guys for the help and tips
Was this
answer
helpful?
Yes
No
Sunday, November 6th, 2016 AT 8:59 AM
Tiny
SATURNTECH9
  • EXPERT
Your welcome were here to help tell all your friends about us.
Was this
answer
helpful?
Yes
No
+1
Sunday, November 6th, 2016 AT 9:35 AM

Please login or register to post a reply.

Recommended Guides