Blower motor/resistor

Tiny
TOYSOURC
  • MEMBER
  • BMW 525
I have a 94 525i with about 275,000 miles. I think the engine is called an e34 if I am not mistaken. I know it is the straight 6. The problem is with the blower motor. It stopped working, then it started working off and on but would be delayed in working. You could get in start the car and turn on the fan with no results, then a few minutes or so later it would work. Stop the car and it might or might not work again. Now it seems to have stopped completely. I have tried to read up on this, but have gotten many different messages. What I want to know is if the 94's have the box type resistor or the sword type resistor and where do I look to find out? Thanks.

Ron
Do you
have the same problem?
Yes
No
Sunday, January 21st, 2007 AT 5:17 PM

2 Replies

Tiny
CARUNDELL
  • MEMBER
Hey Ron,
My data base does not show me which type. All I have is the removal procedure. Remove carpeted trim panel from left center console, remove additional trim panel, the resistor pack is located in the heater "box", remove electrical connector and remove
resistor pack. Let me know!

Chris
Was this
answer
helpful?
Yes
No
Monday, January 22nd, 2007 AT 1:36 PM
Tiny
BAIDYA_FAMILY
  • MEMBER
Hi Ron,

I have 1995 BMW 525i. I have exact same problem with A/C blower motor. Could you fix your car? Can you give me some tips? What did you have to replace? Blower motor registor or blower motor itself?

Thanks
Tapas
Was this
answer
helpful?
Yes
No
Monday, June 18th, 2007 AT 11:57 AM

Please login or register to post a reply.

Recommended Guides