1987 BMW 325 broken speedometer

Tiny
RUTH82
  • MEMBER
  • 1987 BMW 325
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 25,000 MILES
I thought it was a blow fuse but have replace it with new ones, I know I can fixed it but have no idea what I am looking for. Help
Do you
have the same problem?
Yes
No
Thursday, April 3rd, 2008 AT 6:03 PM

3 Replies

Tiny
HAGERTP
  • MEMBER
I am unsure of your question. Do you have a problem with the instrument cluster? Is the speedometer not working? If the speedo is the issue then you may have a problem with the driver chip in the speedo. Replacement or repair is a possibility. Please repost if more assistance is needed. Dr. Hagerty
Was this
answer
helpful?
Yes
No
Thursday, April 3rd, 2008 AT 8:20 PM
Tiny
RUTH82
  • MEMBER
The speedo just stop working. I thought it was a fuse but I replace them with all new ones.
Was this
answer
helpful?
Yes
No
Friday, April 4th, 2008 AT 1:09 PM
Tiny
HAGERTP
  • MEMBER
Thanks for your response. It certainly seems like the speedo driver chip from here, I recommend removing the instrument cluster and inspecting the unit after disassembly. It is likely that the driver in the speedo has failed, I also request inspection of the service interval board(the one with the batteries attached) As stated earlier, replacement of the cluster might be an easier way to address this issue, if so, a salvage yard might be a suggestion that would help. Call Autobahn dismantling @ (619)444-2290 and speak to either John or Sean. Tell them I sent you.
Was this
answer
helpful?
Yes
No
Friday, April 4th, 2008 AT 2:25 PM

Please login or register to post a reply.

Sponsored links