Blower fan not working?

Tiny
FINK4683
  • MEMBER
  • 1997 CHEVROLET BLAZER
  • 4.3L
  • V6
  • 4WD
  • AUTOMATIC
  • 96,000 MILES
Hello,

The blower fan isn't working at any speed. The HVAC fuse was okay, I tried a different one just to be sure. Put a new resistor in still not working. Used alligator clamps from battery to blower and the blower will run. Used a test light to the fan harness and nothing. Used test light on relay and only the big reddish orange wire had power. Noticed the purple 30 wire had a burnish spot looked maybe to me on the relay. But plugged the blower harness into the relay next to it and still nothing. Not sure if there is something wrong with the blower? Or the switch inside the dash? Couldn't get power on the purple wire on the relay harness, just the large reddish orange wire. All test were with the key on the fan on low and high. Any help would be great. Thanks
Sunday, January 8th, 2023 AT 1:32 PM

7 Replies

Tiny
FINK4683
  • MEMBER
  • 10 POSTS
Also, I just ran an alligator clamp from positive on battery to a needle probed into the purple wire right behind the harness plug in and it spun the blower. But there was no power on that wire without the supplemental support from the battery. So still unsure what's going on?
Was this
answer
helpful?
Yes
No
Sunday, January 8th, 2023 AT 2:38 PM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,614 POSTS
It sounds like the HVAC control module is not working. Can we check for power at the brown wire at the c1 connector? Here is a wiring diagram so you can see what I am talking about. Also, this guide can help you test for power.

https://www.2carpros.com/articles/how-to-use-a-test-light-circuit-tester

Check out the images (below). Let us know what happens and please upload pictures or videos of the problem
Was this
answer
helpful?
Yes
No
Monday, January 9th, 2023 AT 11:12 AM
Tiny
FINK4683
  • MEMBER
  • 10 POSTS
Okay thanks, can I check it at the resistor harness, or do I need to pull the module out of the dash to check for power on the brown wire? I haven't pulled the module out yet.
Was this
answer
helpful?
Yes
No
Monday, January 9th, 2023 AT 1:25 PM
Tiny
FINK4683
  • MEMBER
  • 10 POSTS
Alright, giving an update. It's a long story, but I ended up getting the fan to work again. So, thanks for all the help with this!
Was this
answer
helpful?
Yes
No
Monday, January 9th, 2023 AT 5:37 PM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,614 POSTS
Great, what was wrong?
Was this
answer
helpful?
Yes
No
Tuesday, January 10th, 2023 AT 12:43 PM
Tiny
FINK4683
  • MEMBER
  • 10 POSTS
It wasn't my vehicle, but the HVAC knob selector broke, and the person said the knob broke and the fan is broke too cause it wouldn't turn on. So I got to thinking after testing the brown wires in the dash that maybe the knob is just off. And sure enough it just needed to be turned to a selection with a pair of pliers. So that's what it was. Thanks for your help.
Was this
answer
helpful?
Yes
No
Tuesday, January 10th, 2023 AT 12:59 PM
Tiny
KEN L
  • MASTER CERTIFIED MECHANIC
  • 43,614 POSTS
Thanks for letting us know, we are here to help, please use 2CarPros anytime.
Was this
answer
helpful?
Yes
No
Wednesday, January 11th, 2023 AT 11:24 AM

Please login or register to post a reply.

Sponsored links