Blance rate fuel injectors

Tiny
BOBBYPUE DOPEHI
  • MEMBER
  • 2011 CHEVROLET AVEO
  • 1.6L
  • 4 CYL
  • 2WD
  • AUTOMATIC
  • 127,000 MILES
I replaced cylinder one fuel injector I need to know if my balance and pulse rate is in good specs. Also my GM AFR command is 1. 7:1. I did put a new mass air flow sensor on but no codes or check engine light. Thank you.
Do you
have the same problem?
Yes
No
Wednesday, June 12th, 2019 AT 5:59 AM

8 Replies

Tiny
SCWICKEDSTANG
  • EXPERT
Hello,

It is a complicated formula that your vehicle's Power-train Control Module (PCM) uses to calculate the exact time to keep your vehicle's fuel injectors open, but it looks okay. The one value that I see on there that is out of whack is the Air:Fuel Ratio. Usually your vehicle is trying to keep the Air:Fuel ratio as close to stoichmetric as usual, which is 14.7:1. It looks like your PCM is commanding 1.7:1 which is so rich it would completely flood your engine and not make run. I could be seeing things though. Is your vehicle running fine?

Thanks,
Alex
2CarPros
Was this
answer
helpful?
Yes
No
+1
Wednesday, June 12th, 2019 AT 6:40 AM
Tiny
BOBBYPUE DOPEHI
  • MEMBER
Yes, no smell from exhaust a little hesitation. No check engine, good fuel pressure.
Was this
answer
helpful?
Yes
No
Wednesday, June 12th, 2019 AT 7:33 AM
Tiny
BOBBYPUE DOPEHI
  • MEMBER
Here is a video of my o2 sensors:
Was this
answer
helpful?
Yes
No
Wednesday, June 12th, 2019 AT 4:20 PM
Tiny
KEN
  • ADMIN
This looks good but I need to ask have you serviced your throttle bore? We should check fuel pressure as well it could be a weak pump. here are two guides to help us fix it:

https://www.2carpros.com/articles/engine-hesitates

and

https://www.2carpros.com/articles/throttle-actuator-service

Please run down these guides and report back.
Was this
answer
helpful?
Yes
No
+1
Monday, June 17th, 2019 AT 12:53 PM
Tiny
BOBBYPUE DOPEHI
  • MEMBER
It has new pump and throttle body, hesitation was fixed. I had loose bolts on A/C compressor. However Air:Fuel Ratio is showing 1.7:1 that's why I asked about 02 sensor. The static pressure is holding no more then 5psi in 1 minute and it is holding.
Was this
answer
helpful?
Yes
No
Wednesday, June 19th, 2019 AT 3:47 PM
Tiny
KEN
  • ADMIN
Glad you got it fixed, something must be off on the monitoring because at 7 to 1 it would have tons of black smoke out the exhaust pipe. You can try a new primary oxygen sensor but if it runs good you are good to go.

Here is a guide to walk you through the replacement and diagrams below you show you how on your car:

https://www.2carpros.com/articles/how-to-replace-an-oxygen-sensor

Check out the diagrams (below). Please let us know what you find.
Was this
answer
helpful?
Yes
No
+1
Thursday, June 20th, 2019 AT 12:21 PM
Tiny
BOBBYPUE DOPEHI
  • MEMBER
Thank you all.
Was this
answer
helpful?
Yes
No
Thursday, June 20th, 2019 AT 6:18 PM
Tiny
KEN
  • ADMIN
Use 2CarPros anytime, we are here to help. Please tell a friend.
Was this
answer
helpful?
Yes
No
Friday, June 21st, 2019 AT 2:00 PM

Please login or register to post a reply.

Recommended Guides