Battery drain, alternator, starter motor, starter solenoid?

Tiny
PETROLHEAD73
  • MEMBER
  • 2006 JAGUAR X-TYPE
  • 2.2L
  • TURBO
  • 2WD
  • MANUAL
  • 150,000 MILES
Hi.

Please HELP.

Drove my car 20miles got out for 5mins then completely dead when I tried to start it. I seem to remember a slight clicking sound. Called breakdown he attached a boaster starter and it started straight away. He then attached a brand knew battery to my car and followed me home, car drove fine(no power lose)Breakdown put my original battery back on the car and I then recharged the battery fully.

Following day I started car, started as normal drove as normal I took it for granted It had just been a flat battery.

I drove for 3hrs. Got out for 5mins, when I returned to start car it started again. Five miles down the road battery light came on (for the first time) I stopped in a Carpark when I tried to restart my car after 10 mins car dead just slight clicking sound again. I used jump leads to start it(started straight away)

I drove to garage brought a new battery because needed to get home.

Driving home battery light came on after driving for 10 mins and stayed on the whole journey home which took 3hrs! Other then that car drove as normal. Lights on not dimmed at all, same as always.

Next morning car started. But battery light on. Been charging battery on and off ever since(about 4days)

Driven car 3 times on 15mins journeys just to pick someone up so I've not needed to stop and restart my car while away from home.

Last time I drove it my interior dome light was flickering on and off every so often along with the tailgate open light.

Haven't driven car since.(Yesterday)

Now when I think of this I had the same thing happen with flashing dash light(battery) and interior dome light day or so before my battery died first time.

Car hasn't been dead since although it's a new battery but battery light has been on all the time. Haven't had a dead battery or had a problem starting it but it has been on charge on and off to keep battery topped up. I haven't done any readings or checking of wires etc I'm not mechanically minded. Radio works, interior lights, all electronic pack inside car works even when battery is dead, so do the headlight. HELP what could this be.
Breakdown told me it needed a new alternator.
Someone else suggested starter solenoid.
Is it still safe to drive to garage to get it checked out

Would be great to hear others ideas on this

Thanks
Do you
have the same problem?
Yes
No
Saturday, March 26th, 2016 AT 9:09 AM

2 Replies

Tiny
HMAC300
  • EXPERT
This may be a charging problem or a short check fuses in pic and connections for corrosion. Then check belt as it may be slipping recommended belt and tensioner replacement is 60,000 mi. Finally check for a parasitic draw it's covered under electrical on our site
Was this
answer
helpful?
Yes
No
+1
Saturday, March 26th, 2016 AT 12:29 PM
Tiny
PETROLHEAD73
  • MEMBER
Thanks
I'll keep you posted:)
Was this
answer
helpful?
Yes
No
Saturday, March 26th, 2016 AT 12:56 PM

Please login or register to post a reply.

Sponsored links