Bad CAM shaft sensor

Tiny
MARKKOPF
  • MEMBER
  • 2012 TOYOTA CAMRY
  • 4.1L
  • 2,000,000 MILES
Can shaft sensor bank a was the code. Replaced sensor, after driving a few miles light came on again. Three one I replaced facing engine was on the back right.
Do you
have the same problem?
Yes
No
Friday, September 11th, 2020 AT 4:00 PM

3 Replies

Tiny
KASEKENNY1
  • EXPERT
Let's start with the actual code. The reason is we need to pull the testing for it and run through what is required.

https://www.2carpros.com/articles/checking-a-service-engine-soon-or-check-engine-light-on-or-flashing

Also, can you confirm the engine that you put on the heading? It says 4.1L but I don't show that offered in the USA. Is this located outside the USA?

If so, we are going to be limited in our assistance as we don't have manuals for export vehicles but we should be able to figure this out. Thanks

Was this
answer
helpful?
Yes
No
Friday, September 11th, 2020 AT 5:15 PM
Tiny
MARKKOPF
  • MEMBER
P0012. I just know it's a 4 cylinder.
Was this
answer
helpful?
Yes
No
Monday, September 14th, 2020 AT 12:29 PM
Tiny
KASEKENNY1
  • EXPERT
Okay. I attached the testing. More then likely you jumped a tooth in the timing and it is setting this code. We need to run through all this testing and see what happens. Clearly we can't guess at it as there is not a next most likely cause. Normally it is a sensor but we need to run through this to find out where the issue is.

Let me know if you have questions. Thanks
Was this
answer
helpful?
Yes
No
Monday, September 14th, 2020 AT 6:56 PM

Please login or register to post a reply.

Sponsored links