Backfire through exhaust black smoke no power

Tiny
CSONGOR
  • MEMBER
  • 1990 CHEVROLET SUBURBAN
  • 235,000 MILES
When cold the 350 runs fine when it gets to operating temp it begins to misfire black smoke and had no power, checked plug, wires, cap & rotor, tps fixed two vacuum leaks checked cts has new fuel pump filter timing doesnt jump around while checking with timing light no cel on at wits end broke down on side of road hrading to wisconsin pulling a 16 foot enclosed trailer. Out in the middle of nowhere no money for a tow or mechanic.
Do you
have the same problem?
Yes
No
Monday, August 5th, 2013 AT 11:57 AM

7 Replies

Tiny
HMAC300
  • EXPERT
You are going to have to scan for codes and check fuel pressure first to see what is wrong with it
Was this
answer
helpful?
Yes
No
Monday, August 5th, 2013 AT 1:04 PM
Tiny
CSONGOR
  • MEMBER
No check engine light on fuel pressure at 15 psi
It is running rich exhaust is very acrid.
Was this
answer
helpful?
Yes
No
Monday, August 5th, 2013 AT 3:54 PM
Tiny
HMAC300
  • EXPERT
Check for a vacuum leak under tbi unit gasket may hav blown also check if hose is soft going tomap sensor it may have sucked together and screwing up map. If it is backfiring it may be a rocker arm or cam problem or valve
Was this
answer
helpful?
Yes
No
Monday, August 5th, 2013 AT 4:16 PM
Tiny
CSONGOR
  • MEMBER
No vacuum leaks used a squirt bottle with a cap full of soap all the vacuum lines are good no cracks no soft spots as I said the motor is running very rich you take the tan and black wire off under the dash for the computer controled timing it runs great can I drop an hei distributer in and screw the computer?
Was this
answer
helpful?
Yes
No
Monday, August 5th, 2013 AT 4:52 PM
Tiny
CSONGOR
  • MEMBER
Got all the tools needed in trailer ran compression check on all cylinders and got between 140 and 125 on all eight seems to be electrical. A bad sensor or something as I said it is extremely rich.
Was this
answer
helpful?
Yes
No
Monday, August 5th, 2013 AT 4:55 PM
Tiny
CSONGOR
  • MEMBER
I have a race truck in the trailer. The truck has no hitch or lights buti have an extra intake carb and distributer and fuel pressure regulator that will fit the motor should I say screw it and put the race parts on really dont want to do it but I guess I will in the morning.
Was this
answer
helpful?
Yes
No
Monday, August 5th, 2013 AT 11:32 PM
Tiny
HMAC300
  • EXPERT
Fuel pressure should be 9-11 13 at most so it may be a regulator has gone bad or a partially blocked return line. I can't think of anything else try crossing A&B on aldl and see if you got any codes, it could l be a bad pickup coil indist or ignition module. Also check inside dist cap for rotor button being to short. I really can't think of anything else.
Was this
answer
helpful?
Yes
No
Tuesday, August 6th, 2013 AT 6:23 AM

Please login or register to post a reply.

Recommended Guides