Back to ask for ideas on transmission

Tiny
DAVID SHEP68
  • MEMBER
  • 2005 JEEP WRANGLER
  • 4.0L
  • V6
  • 4WD
  • AUTOMATIC
So I am trying to diagnose this 2005 jeep. I got it after 2 other shops replaced the tps and trans relay the battery and the ignition switch to solve a shifting problem that occasionly puts the trans into limp mode. I read the manuals and have driven it hot and cold. Checked wires and connections. The vehicle will drive and shift almost normaly but I have to trip shift by letting up on the pedal into second and third. It has stayed in first. Just had second gear. Acts like the faults for trans temp to high. Cleared the codes and the only one that keeps comming up is 0122. Tps vol low the transmission works so I dont want to replace it. Is the issue inside and tripping other codes or is it the pcm tcm ( one unit)? The chk light comes on if I clear the codes and if the rpm into second is high. Not at idle and not reverse. Any ideas?
Do you
have the same problem?
Yes
No
Sunday, August 17th, 2014 AT 6:51 PM

1 Reply

Tiny
JACOBANDNICKOLAS
  • EXPERT
There is a list of possible causes for this. Let me know which you have already checked.

Throttle position sensor (TSP) sensor sweep
5 volt supply circuit open
5 volt supply circuit shorted to ground
Faulty TPS
TPS 1 signal circuit shorted to ground
TPS 1 signal circuit shorted to the sensor ground circuit
Faulty PCM
Transmission control module
Was this
answer
helpful?
Yes
No
Sunday, August 17th, 2014 AT 7:25 PM

Please login or register to post a reply.

Recommended Guides