1993 Audi 100 fails smog NOx test for California

Tiny
WPATTERS1229
  • MEMBER
  • 1993 AUDI 100
  • 6 CYL
  • FWD
  • AUTOMATIC
  • 203,000 MILES
The audio 100 v6 had 203 k but two years ago I had both caytalitc converters replaced and the NOx levels where both around 49 way below the 700 which is the high level in CA.
Now two years later everything else in the test was exactly the same but the NOx levels are now above the max level around 750. What could be the problem?
I have heard the things to do is replace the air cleaner, get some of that guarntee to pass gas additive etc. I have replace the plugs and new wires. It uses a magneto so there is no distributor to mess with.

Not sure about NOx sensors.

Any help would be greatly appreciated.

Thanks
Do you
have the same problem?
Yes
No
Sunday, December 28th, 2008 AT 2:46 PM

2 Replies

Tiny
RASMATAZ
  • MEMBER
Check the EGR valve its job is to reduce the formation of oxides of nitrogen by lowering the combustion temperature
Was this
answer
helpful?
Yes
No
Sunday, December 28th, 2008 AT 3:02 PM
Tiny
WPATTERS1229
  • MEMBER
I just have to find it on the engine and then test if the diaphram is working. I know how to apply straight vacuum to see if it changes the engine speed but if the problem is the electrical then I guess that will have to mean shop time which is $$$ that I do not have. Ugh.

Thanks for the reply :)
Was this
answer
helpful?
Yes
No
Sunday, December 28th, 2008 AT 7:46 PM

Please login or register to post a reply.

Related Smog Fail Content

Fail Your Smog Test? Fix it Fast
VIDEO

Recommended Guides