1995 Geo Prizm turn signa and flasher failure

Tiny
OIII88
  • MEMBER
  • 1995 ALL OTHER MAKES ALL OTHER MODELS
I just purchased a 1995 geo prizm for my wife. The turn signals and hazard lights stopped working. I changed the flasher fuse Under the dash and that did not fix it . Is there another fuse that could be causing it? I was told it might be the turn signal switch its self but I can not see that being a problem considering the hazards and turn signals work of diffrent switches. Any help would be greatly appreciated. Thanks < sorry I know I asked it once but kid deleted it thinking he was closing it:|>
Do you
have the same problem?
Yes
No
Friday, March 17th, 2006 AT 1:53 PM

5 Replies

Tiny
PEPPERMRJ
  • MEMBER
Check the fuse under the hood. It is # 15 in a US corolla. The lid to the box should have a listing. Hazard-horn 15 amp. Looks can be deceiving, use on ohm meter or test light.

Sharing of fuses, fuseible links, and circuit breakers are common to conserve space and wire. Check even what might seem unrelated. Also the circuit breakers on these vehicles have to be manualy reset.

Good hunting and let us know. :)
Was this
answer
helpful?
Yes
No
+1
Saturday, March 18th, 2006 AT 11:08 PM
Tiny
OIII88
  • MEMBER
How do you manualy reset the ciruit breaker?
Was this
answer
helpful?
Yes
No
-1
Sunday, March 19th, 2006 AT 1:24 AM
Tiny
OIII88
  • MEMBER
Thanks for the fast responce now I got to try and locate the darn thing I know nothing of these foreign electrical systerms. And on autozone I cant find the breaker under componant location.
Was this
answer
helpful?
Yes
No
-1
Sunday, March 19th, 2006 AT 11:10 AM
Tiny
PEPPERMRJ
  • MEMBER
Did you try the fuse first. Use the navigation on their site to show the electrical box locations. Should have 1 or 2 under the hood drivers side front and 2 inside the cabin.
Was this
answer
helpful?
Yes
No
Sunday, March 19th, 2006 AT 11:16 AM
Tiny
OIII88
  • MEMBER
Just wanted to update you all. I got it fixed today. Turns out when the mrons installed a new stereo. They unplugged the flasher switch itself for the Hazards. I removed the little face place while putting in a new radio and the wire dropped down I plugged it back into the hazards button and the signals now work. Anyways thanks for all the help you all offered. :D
Was this
answer
helpful?
Yes
No
+2
Sunday, April 30th, 2006 AT 12:50 PM

Please login or register to post a reply.

Recommended Guides