1990 Galant 2.0 shuts down after running for a few seconds

Tiny
DRFINN2K2
  • MEMBER
  • 1990 ALL OTHER MAKES ALL OTHER MODELS
I'm trying to get a Galant running and having no luck. The thing keeps shutting itself down after it fires up. I have installed a NEW computer and the same thing happens.
I am thinking a sensor is shutting it down? But the check engine light does not come on.
This car is equiped with California emmsions if that make any difference. I was just wondering if any one had any advise where to start.
I would also be very appreciative of a sensor diagram, since I am having a hard time finding the darn things.

Thank You
Danny
Do you
have the same problem?
Yes
No
Tuesday, March 6th, 2007 AT 7:30 PM

2 Replies

Tiny
2CEXPT
  • MEMBER
Check the fuel pressure KOEO-if okay---open up the EGR and inspect for carbon-clean it up good.

Sometimes a bad ignition switch will do that when it returns back to the run position

Here's a trick power up the coil with an inline fuse from the battery to the coil positive Now crank it if it runs you need an ignition switch.
Was this
answer
helpful?
Yes
No
Wednesday, March 7th, 2007 AT 3:39 AM
Tiny
JOSHWITDATALON
  • MEMBER
Also some other ppossibilities would be, Loose or faulty electrical connections at disrtibutor(or crank angle sensor), the coil or the alternator. 2nd Vaccum leak at the gasket between the intake manifold and the throttle body or between the intake manifold and engine. Hope I helped ya even a little bit. Let me know how it goes and if u got any more questions.
Was this
answer
helpful?
Yes
No
Wednesday, March 28th, 2007 AT 4:30 AM

Please login or register to post a reply.

Related Check Engine Light Content

Code Read Retrieval/Clear Mercedes-Benz C230
VIDEO

Sponsored links