03 Ranger brake problem

Tiny
REMRAF04
  • MEMBER
  • 2003 ALL OTHER MAKES ALL OTHER MODELS
03 ranger w. 24,000 miles has VERY hard brake petal, getting worse, and hesitates before braking
Do you
have the same problem?
Yes
No
Sunday, September 10th, 2006 AT 8:33 AM

3 Replies

Tiny
REMRAF04
  • MEMBER
This is my question and I think I've got the answer. I think brake booster is leaking. Problem of hard pedal is mostly after it's been sitting. After vehicle has been running, petal has play but makes a constant hiss when brake is pushed, like something is leaking. There is also a check engine light on, which I hope is related in that vacuum is constantly pulling.
Can someone confirm that I'm on right track and tell me if brake booster iinstalation is hard. Directions make it appears pretty daunting.
Was this
answer
helpful?
Yes
No
Sunday, September 10th, 2006 AT 4:00 PM
Tiny
NOS
  • MEMBER
Best way to find out if it is brake booster is to take the big rubber line off the booster and plug it so it can't leak then start the truck if the hiss is gones away yes it is the booster. There not really that hard to do. 2 -15mm nuts takes master cyclinder loose. Don't break lines loose at master cyclinder just real easy move it out of the way.A leaky booster could cause several things to to happen on the truck loss of fuel milage, poor idle, poor exceleration, stumbling etc. Ok back to the booster go inside the truck look under dash you'll see the rod coming through the firewall going to the pedle there is a steel clip through the pin that holds the rod inplace, watch how this comes apart cause you will have to put it all back just right or your brakelights won't work cause your brakelight switch is also mounted there. Then take a 13mm socket and an extension take the four nuts off the booster just follow the rod towards the firewall and you will see the four nuts remove them and pull the booster out. And just go reverse to go back peice of cake.(NOS)
Was this
answer
helpful?
Yes
No
Monday, September 11th, 2006 AT 10:25 PM
Tiny
REMRAF04
  • MEMBER
Replaced. Was bad and fixed check engine problem
Thanks NOS
Was this
answer
helpful?
Yes
No
Tuesday, September 12th, 2006 AT 9:22 AM

Please login or register to post a reply.

Recommended Guides