2002 Acura RSX CEL P1077& P0661

Tiny
TEESHARK
  • MEMBER
  • 2002 ACURA RSX
  • 4 CYL
  • 2WD
  • MANUAL
  • 47,500 MILES
I need an expert opinion, as this has been an ongoing issue? I got this code, since last Dec 2009, and was unaware that my car might of been under warranty(emission 7yrs), unfortunately was not fixed or looked at until Jan. 2010. My first ASE independent mechanic replaced the IMRC valve. Re-setted the light and then within
7 miles of leaving the shop, the CEL returned. So after going back and forth with him, he thinks it is position sensor, in the intake manifold realm, but he was never around til the late AM, so my sister referred me to her mechanic. He checked everything(diagnostic testing with the trouble code stated) by the Acura books(alldata), and found only a bent vacuum hoses, so they replaced it, reset light and voila, that seem to work, but it was only temp. It seems the CEL is back with the same codes, no matter long distance or city driving, at times the CEL does go out, but returns after later? The mechanic says they did everything to try to resolve issue and says the only thing that might fix it is to update the ECM/PCM software if it is not the latest? Or try a new known good ECM/PCM unit? Because the the sensor side, measures resistance btwn IMRC valve position sensor 3P connector terminals #2 and #3 while applying vacuum to IMRC actuator -was measured at 9.3kohm. Sorry this is long, but the dealership can only replace the PCM, at big $$ so I have been told, and want a mechanic and/or car expert opinion, as I hate to shell out $$ to replace this unit and later find out this doesn't fix the problems. Overall the car seems to run fine, drove to vegas 2x, used cruise control off and on, get about 30mpg on freeway. OOh in between the fixes I was able to pass smog.
Thx in advance
Do you
have the same problem?
Yes
No
Thursday, March 18th, 2010 AT 1:08 AM

2 Replies

Tiny
KHLOW2008
  • EXPERT
Hi teeshark,

Were the codes recurring same as before repairs?

If the repairs were carried out as per instructions and still does not solve the problem, wires checked, valves cleaned/replaced etc, then you would have to update the PCM and replace it if updating does not work.
Was this
answer
helpful?
Yes
No
Monday, March 22nd, 2010 AT 12:17 PM
Tiny
2CARPROS LINSEY
  • MEMBER
Thank you for using 2CarPros. Com. We appreciate your donation and look forward to helping you in the future.
Was this
answer
helpful?
Yes
No
Tuesday, March 30th, 2010 AT 4:52 PM

Please login or register to post a reply.

Recommended Guides