SPUTTERING AT 3000RPM AND WONT GO PAST 35000

1990 Acura Integra

Tiny

icurpp

August, 10, 2007 AT 3:20 AM

My 16yr old got this car a week ago. I know the timming belt was just replaced or that what he said. He told here it needed a new water pump and it was sitting for a year.
I got the car home, 1/4mile, and looked at it the waterpump seems fine but I cant get the car to run over 3000rpms it sputters like it has a miss at that point when I give it gas. But at an idiel it runs fine.
I hear a high pitch whine on and off that sounds like it is comming from the distributor or shaft but I only have one bolt tight now from playing with the timming. The engine light is also on. At this point I cant tell if it has enough fuell pressure but Im an old school small block person. Thanks for you help.
I have codes 4 and 7 crank and throtel sensers could it be both?

FOUND 1589 RELATED QUESTIONS

1 Answer

Tiny

Bruce Hunt

August, 10, 2007 AT 8:50 AM

I would be interested to know what you have found with the timing. I suspect that you are attempting to set it by ear. What I believe you might find is that the timing belt was not put on quite right. It might be a lug or two off. Have you got a timing gun to check and see how close things are? The timing being off can play hob with those sensors.

Please login or register to post a reply.

Code Read Retrieval/Clear
Code Read Retrieval/Clear Scion XD
Code Read Retrieval/Clear Mercedes-Benz C230
Code Read Retrieval/Clear - Dodge Stratus
 Step by Step video GMC Yukon XL 2000-2006