Stereo installation

Tiny
KEND.KD75
  • MEMBER
  • 1999 FORD RANGER
  • 3.0L
  • 6 CYL
  • 270,000 MILES
Hooking up new stereo. According to your wiring diagram I have two fused ignition wires. Red/black and yellow/black. In my old harness I have two beige/black and one black which are all grounds. How should I be connecting everything?
Do you
have the same problem?
Yes
No
Monday, February 4th, 2019 AT 2:36 PM

13 Replies

Tiny
KENW1
  • EXPERT
Thanks for visiting 2CarPros.

If you are installing an aftermarket radio the wiring is as follows.

Light green and violet to yellow.

Yellow and black to red.

Black to black.

The speakers are orange and red to purple with black stripe.

Brown and pink to purple.

White and light green to grey.

Dark green and orange to grey with black stripe.

Grey and light blue to green with black stripe.

Tan and yellow to green.

Orange and light green to white.

Light blue and white to white with black stripe.

I'll post the wiring diagram information below.
Was this
answer
helpful?
Yes
No
-1
Tuesday, February 5th, 2019 AT 5:23 PM
Tiny
KEN
  • ADMIN
Hello,

Here is the complete radio wiring so you can see what goes to where. Check out the diagrams (below). Please let us know if you need anything else to get the problem fixed.
Was this
answer
helpful?
Yes
No
+1
Tuesday, February 5th, 2019 AT 5:46 PM
Tiny
KEND.KD75
  • MEMBER
I think I got it. The red/black just gets capped off and the two green/black get tied together and the single black goes to the new stereo?
Was this
answer
helpful?
Yes
No
Tuesday, February 5th, 2019 AT 6:03 PM
Tiny
KEN
  • ADMIN
Sound right. Let me know what happens.
Was this
answer
helpful?
Yes
No
Wednesday, February 6th, 2019 AT 12:29 PM
Tiny
KEND.KD75
  • MEMBER
Got dead short somewhere. Blowing fuses.
Was this
answer
helpful?
Yes
No
Wednesday, February 6th, 2019 AT 12:31 PM
Tiny
KEN
  • ADMIN
Do you have the wiring from the new stereo? We need to see it.
Was this
answer
helpful?
Yes
No
Wednesday, February 6th, 2019 AT 12:33 PM
Tiny
KEND.KD75
  • MEMBER
Standard Pioneer hookup.
Was this
answer
helpful?
Yes
No
Wednesday, February 6th, 2019 AT 12:35 PM
Tiny
KEND.KD75
  • MEMBER
It's the same as in the diagram you sent me in that second email yesterday.
Was this
answer
helpful?
Yes
No
Wednesday, February 6th, 2019 AT 12:38 PM
Tiny
KEN
  • ADMIN
Hmm, I don't see it. Can you upload it here to the post?
Was this
answer
helpful?
Yes
No
Wednesday, February 6th, 2019 AT 1:43 PM
Tiny
KEND.KD75
  • MEMBER
Okay, here is what I got. Help!
Was this
answer
helpful?
Yes
No
Thursday, February 14th, 2019 AT 6:10 AM
Tiny
KEN
  • ADMIN
Can you please disconnect all wires except the yellow, red and black to see if the fuse still blows?
Was this
answer
helpful?
Yes
No
Friday, February 15th, 2019 AT 10:30 AM
Tiny
KEND.KD75
  • MEMBER
Did that. No blown fuses. Stereo still not lighting up.
Was this
answer
helpful?
Yes
No
Friday, February 15th, 2019 AT 10:40 AM
Tiny
KEN
  • ADMIN
It should at this point you might have got a bad one. Also none of the remaining wires should go to ground.
Was this
answer
helpful?
Yes
No
Friday, February 15th, 2019 AT 10:44 AM

Please login or register to post a reply.

Recommended Guides