Acceleration is good but surges at any cruising speed

Tiny
/STEVE.GY.16
  • MEMBER
  • 1990 FORD E-SERIES VAN
  • 7.5L
  • V8
  • 2WD
  • AUTOMATIC
  • 105,000 MILES
Class c mh on E350 chassis, well maintained. While passing another vehicle on interstate at full throttle, engine suddenly lost power, went into limp mode; replaced all injectors, distributor, coil and condenser, MAP sensor, fuel press regulator, high press fuel pump, fuel filters, plugs and wires, fuel pump relay, throttle position sensor, fuel line hoses; egr is functioning normally, O2 sensors good, transmission and shifting sensor no problems, engine timing is correct, compression good and consistent on all cylinders, no problem with catalytic converter and there no diagnostic codes, no engine light, fuel press is correct. Engine accelerates well but surges at any cruising speed. Throttle body has been cleaned, air intake system is clean and intact, no vacuum leaks. Please! I need help and cannot find any local tech familiar with this vintage vehicle.460cid, efi, eod parameter hunting
Do you
have the same problem?
Yes
No
Monday, February 22nd, 2021 AT 9:58 AM

2 Replies

Tiny
KEN
  • ADMIN
It sounds like you may have a shorted injector which can shut down the PCM and will have no codes. To be sure these guides can help us test and fix the problem:

https://www.2carpros.com/articles/how-to-replace-a-fuel-injector

and

https://www.2carpros.com/articles/how-to-test-a-fuel-injector

Let us know what happens and please upload pictures or videos of the problem.
Was this
answer
helpful?
Yes
No
Tuesday, February 23rd, 2021 AT 6:34 PM
Tiny
JOSEPH04RODRIGUEZ
  • MEMBER
Dating for sex on "SEXO69. FUN"
Was this
answer
helpful?
Yes
No
Wednesday, March 3rd, 2021 AT 6:58 PM

Please login or register to post a reply.

Sponsored links