2010 Toyota Van engine vibrates and excessive smoke

Tiny
ZEZEYE
  • MEMBER
  • 2010 TOYOTA VAN
  • 85,000 MILES
My car is Toyota Hiace 2010, engine D4D, the problem is while I was driving there was small pool of water on the road and the car sucks the water through the intake manifold and engine stalls. I loosen the glow plug and cranked the engine, the water goes out from the combustion chamber and then I tighten the glow plug and started the engine. The engine started but vibrates and excessive smokes through the exhaust manifold.
Do you
have the same problem?
Yes
No
Sunday, September 1st, 2013 AT 11:56 PM

8 Replies

Tiny
KHLOW2008
  • EXPERT
This is bad. Seems you have hydrolocked the engine briefly resulting in at least one or more connecting rods getting bent.

You would need to rebuild the engine with replacement of connecting rods.
Was this
answer
helpful?
Yes
No
Monday, September 2nd, 2013 AT 7:20 AM
Tiny
ZEZEYE
  • MEMBER
I really appreciate your help and prompt response. Thank you so much.
I WILL DO THAT
Was this
answer
helpful?
Yes
No
Monday, September 2nd, 2013 AT 10:58 PM
Tiny
KHLOW2008
  • EXPERT
Good luck.
Was this
answer
helpful?
Yes
No
Tuesday, September 3rd, 2013 AT 6:13 AM
Tiny
ZEZEYE
  • MEMBER
I thank you so much.

I just dismantled the cylinder head and come to observe that the two pistons, #3 and #4, don't come to top at all, an indication of connecting rod bent as you said earlier.

I am asking you to give me your opinion on the following
1. Shall I change all the connecting rods or only two of them?
2. I was planning to change the piston ring in the mean time, is this a good idea?

Once again I really appreciate your help
Was this
answer
helpful?
Yes
No
Tuesday, September 3rd, 2013 AT 6:31 AM
Tiny
KHLOW2008
  • EXPERT
Have all connecting rods checked/measured and replace as necessary.

It is always good to replace the rings when the pistons have been removed from the cylinder block. Ensure the cylinders do not have excessive wear.
Was this
answer
helpful?
Yes
No
Tuesday, September 3rd, 2013 AT 8:17 AM
Tiny
ZEZEYE
  • MEMBER
Thank you
Was this
answer
helpful?
Yes
No
Tuesday, September 3rd, 2013 AT 11:59 PM
Tiny
KHLOW2008
  • EXPERT
You're welcome.
Was this
answer
helpful?
Yes
No
Wednesday, September 4th, 2013 AT 6:25 AM
Tiny
2CARPROS MIKE
  • ADMIN
Emailed reply:

Hi there,

this is zezeye

I am grateful for your reply last time. My problem now is my car has excessive smoke in the morning and lacks power until it gets hot. It looks ok when it is hot.

Thank you in advance

regards,

Zezeye
Was this
answer
helpful?
Yes
No
Monday, February 16th, 2015 AT 11:16 AM

Please login or register to post a reply.

Recommended Guides