NO FORCE POWER AT STARTING, 1.4 ,, MODEL HERE IN CAIRO, EGYPT

2008 Renault Clio

Tiny

exmacadato

April, 5, 2012 AT 8:42 AM

1) if I run at start, no force power, but if I reach at 20km/ph. My car car is very strong and very fast, problem only at the starting. I changed clutch lining, I changed the spark flag, airfilter and fuelfilter through advice of my mechanic. But no still power at the start running.

2)my clutch is also have a problem, is there an adjustable clutch in my pedal clutch because it hard to push at first gear. Mostly renault clio here in cairo egypt is clutch problem. I don't know why renault company did not solve this problem.

FOUND 50462 RELATED QUESTIONS

3 Answers

Tiny

rasmataz

April, 5, 2012 AT 9:04 AM

Sounds like your clutch is slipping have it checked -start here

Tiny

exmacadato

April, 6, 2012 AT 3:25 PM

Thanks for your reply, and I really appreciate you.
When the mechanic change my clutch lining w/ clutch pressure. Only 3 days for my satisfaction because it is smooth my pedal clutch and to change the gear. After 3 days, my clutch pedal is very hard to push and my first gear is hard.

I HAVE SOME PROBLEM AGAIN. Sometimes when run slow to the bad way/road, my RPM arise, but when I run very fast no problem with my RPM, my mechanic replace accelerator cable and remove my carborator to spray it, imagine 2 bottles of sprayer, but the same problem with my RPM.

THANKS AGAIN.

Tiny

rasmataz

April, 10, 2012 AT 8:13 AM

Check the clutch slave if its hydraulic or if its a cable check adjustment-for your RPM-check fuel pressure and throttle position sensor-If it haven't had a tune-up consider getting it done and see what happens

Please login or register to post a reply.

Crank Angle Sensor Replacement Mercedes Benz
Crankshaft Position Sensor Replace Chevrolet
Fuel Pump Test Chevy Tahoe
Fuel Pump Replacement Ford Mustang
Fuel Pump Replacement Done Right