2008 Chevrolet Impala Washer pump replacement

Tiny
JEFFMAN
  • MEMBER
  • 2008 CHEVROLET IMPALA
  • 3.5L
  • 6 CYL
  • 2WD
  • AUTOMATIC
  • 60,000 MILES
Doesn't work. Also can't find out where the fuse is labeled under. Underneath
Wednesday, October 22nd, 2014 AT 4:25 PM

3 Replies

Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 108,635 POSTS
First, you need to check if there is power to the pump. If there is no power, see the attached pic for WSW fuse (10 amp). If the fuse is good and there is no power and the fuse is good, suspect the power circuit board (PCB) relay as bad.

I don't know if you can identify the fuses / locations. The writing is very small. Look at the attached pic. Starting at the bottom right, count over 3 fuses to the 15 amp one under spare fuses. Next, right above it is another 15 amp fuse for the fog lamps. At the 11 oclock position from the fog lamp fuse is a 10 amp fuse which is for the washer pump.

Let me know what you find of if you have other questions.

Joe
Was this
answer
helpful?
Yes
No
+1
Wednesday, October 22nd, 2014 AT 5:54 PM
Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 108,635 POSTS
Sorry, I forgot to attach the pic.
Was this
answer
helpful?
Yes
No
+1
Wednesday, October 22nd, 2014 AT 5:55 PM
Tiny
JACOBANDNICKOLAS
  • MECHANIC
  • 108,635 POSTS
One last thing I didn't mention was this is the under hood fuse block, not the one in the car.
Was this
answer
helpful?
Yes
No
+3
Wednesday, October 22nd, 2014 AT 5:57 PM

Please login or register to post a reply.

Sponsored links