2008 BMW 335i

Tiny
FORDTRUCK2006
  • 2008 BMW 335
  • 6 CYL
  • AWD
  • AUTOMATIC
  • 50,000 MILES

I added an engine Restore product to the engine. Then I noticed problems after the start.

When at Idle speed the engine bucks and struggles to stay alive? My service engine light is now on and very sluggish on acceleration. I am contemplating dropping the fresh oil/restore and doing the oil change again to see if that helps.
Any recommendations?

Do you
have the same problem?
Yes
No
Monday, January 24th, 2011 AT 3:31 PM

4 Replies

Tiny
DR. HAGERTY
  • EXPERT
  • 9,741 POSTS

The 335 has history with the high pressure fuel pump failing, have you spoken to your BMW service provider?

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Monday, January 24th, 2011 AT 3:34 PM
Tiny
FORDTRUCK2006
  • MEMBER

Well the problem is that as soon as I added that engine restore product the vechicle started having all of those symptoms.

Was this
answer
helpful?
Yes
No
Monday, January 24th, 2011 AT 3:41 PM
Tiny
DR. HAGERTY
  • EXPERT
  • 9,741 POSTS

Then I would agree that the action your were contemplating should be followed through with straightaway.

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Monday, January 24th, 2011 AT 6:05 PM
Tiny
DR. HAGERTY
  • EXPERT
  • 9,741 POSTS

?

Please consider a donation to help us answer more questions.
Was this
answer
helpful?
Yes
No
Tuesday, January 1st, 2013 AT 7:20 AM

Please login or register to post a reply.

Related Engine Low Power Questions

Help us by donating