How do I fix?

Tiny
STUPEDMONKY
  • MEMBER
Hummm. I drove the car Thursday everything was good, got in the car friday morning, the check engine light was on, with the P-0449, I cleared the light and drive 550 miles over 12 hrs, and the check engine light never came back on. So pretty much my Vue is just electronically challenged? Lol
Was this
answer
helpful?
Yes
No
Saturday, November 5th, 2011 AT 3:22 PM
Tiny
SATURNTECH9
  • EXPERT
So like a very intermintant problem without a tech2 to command the vent valve open and closed and a little luck its not going to be easy to find. Have you made sure the terminals to the vent valve arent open?Instead of being closed.
Was this
answer
helpful?
Yes
No
Saturday, November 5th, 2011 AT 4:12 PM
Tiny
STUPEDMONKY
  • MEMBER
There is no ground, and I have noticed over the last 4 days or so, I did the 1200 trip and the hybrid did great, I avraged 33 MPG, the check engine light would only come on if I were to let the enging cool down. Like when I drove 9 hours stright the light never came on once. But when I pulled in to my friends dorm parking lot and let it sit over night, when I got back in the car the next morning, the light would come on for the valve. And then I would clear it and never see it till the next morning.
Was this
answer
helpful?
Yes
No
Tuesday, November 8th, 2011 AT 2:48 PM
Tiny
SATURNTECH9
  • EXPERT
Thats because the evap test is only ran when the engine is cold and the evap vent valve is then closed to do the test. You have a power at the valve all the time the computer closes the valve by supplying a ground to the vent valve to close the evap system. Then the computer pulses the canister purge solenoid open to supply vacuum to the gas tank to check for leaks. Then there is a fuel tank. Pressure sensor to measure vacuumin the tank. That reads a voltage value back to the computer and the computer can tellby the voltage value if there is a leak in the evap system. Your code deals with the vent valve itself I can guide you thru the trouble tree but requires a tech2 scan tool to open and close the vent valve and show its commanded state. Its a very basic trouble tree.
Was this
answer
helpful?
Yes
No
Tuesday, November 8th, 2011 AT 5:07 PM
Tiny
STUPEDMONKY
  • MEMBER
Well funny enough, I just got a job with a auto dealership that used to be a saturn befor it shutdown. So I have a tech2 scaner on my tool box at work. So I do plan to bring the car to work at some point this week. So if it the computer fault, is that just a flash? Or a new ecu?
Was this
answer
helpful?
Yes
No
Thursday, November 10th, 2011 AT 2:35 AM
Tiny
SATURNTECH9
  • EXPERT
If it doesnt command on and off see if there is a ground to the none power wire. If not it could be the wire terminal tightness or ecm if its the ecm its not a flash calibration its a bad ecm. Let me know if you can command the vent valve open and closed by using the special test on the tech 2.
Was this
answer
helpful?
Yes
No
Thursday, November 10th, 2011 AT 3:36 AM
Tiny
STUPEDMONKY
  • MEMBER
Ok, me and my co-worker just possibly fix the problem. We took down the evap canister took out the valve, bench tested the valve, and it works perfectly. So we put it all back together, scanned the computer, waited for vacuum to build up in the tank/ canister, and then commanded the valve open. And the vacuum dropped to 0% so. We are thinking that the valve was possably stuck open due to sand or dirt.
Was this
answer
helpful?
Yes
No
Friday, November 11th, 2011 AT 9:07 PM
Tiny
SATURNTECH9
  • EXPERT
I have seen those valve just stick open without any debris hopefully that fixes your problem.
Was this
answer
helpful?
Yes
No
Friday, November 11th, 2011 AT 9:30 PM
Tiny
STUPEDMONKY
  • MEMBER
So far so good! I started the car this morning, and the light never came on! So hopefully!
Was this
answer
helpful?
Yes
No
Sunday, November 13th, 2011 AT 3:22 AM
Tiny
SATURNTECH9
  • EXPERT
Alright sounds good keep me posted.
Was this
answer
helpful?
Yes
No
Sunday, November 13th, 2011 AT 4:18 AM
Tiny
STUPEDMONKY
  • MEMBER
Will do, thank you very much for all your help :)
Was this
answer
helpful?
Yes
No
Sunday, November 13th, 2011 AT 4:22 AM
Tiny
SATURNTECH9
  • EXPERT
Your welcome thats what were here for.
Was this
answer
helpful?
Yes
No
Sunday, November 13th, 2011 AT 5:20 AM
Tiny
STUPEDMONKY
  • MEMBER
Bad news. This morning it pulled the same codes again. This time I took the tech 2 at work and scaned it. It is showing 0.00 volts at the hybrid batt. And with my volt meter its showing 43 volts.
Was this
answer
helpful?
Yes
No
Friday, November 18th, 2011 AT 7:03 PM
Tiny
SATURNTECH9
  • EXPERT
What is the exact code number you have?
Was this
answer
helpful?
Yes
No
-1
Friday, November 18th, 2011 AT 7:53 PM

Please login or register to post a reply.

Recommended Guides