2007 Hyundai Accent Gearing (transmission )

Tiny
COORS697
  • MEMBER
  • 2007 HYUNDAI ACCENT
  • 42,600 MILES
Seems when trans oil gets hot or on old start my 07 accent automatic wants to gear down on its own, happens usually when driving under 50 km an hour. Also when coming to stop, it won't move forward unless give alittle more extra on the accelerator. Also from park to either reverse or forward there is a delay in doing so but when moving forward will change gears perfectly. Hyundai told mr to change trans oil and install 2 pulse generators on transmission, did that but $370 later still same problem. Please, please help me


Reggie
Do you
have the same problem?
Yes
No
Thursday, June 27th, 2013 AT 6:23 AM

6 Replies

Tiny
SEANGRANT00
  • EXPERT
After getting the work done did you take it back to the dealership to let them know the problem still exists? I would do that first and see what they say. Sounds like it could be an electrical problem, like a pressure regulating solenoid, shift solenoid, overdrive solenoid, kick down switch needs adjustment or replacement.
Was this
answer
helpful?
Yes
No
Thursday, June 27th, 2013 AT 12:46 PM
Tiny
COORS697
  • MEMBER
The hyundai garage told me where codes were detected at another garage they weren't liable for parts even though they said same as the other garage. After this they kinda figured it was torque converter but I feel same cause sometimes after trans gets hot it won't shift out of 2nd gear but turn off ignition and start again everything is back to normal.
Was this
answer
helpful?
Yes
No
Thursday, June 27th, 2013 AT 4:11 PM
Tiny
SEANGRANT00
  • EXPERT
This could be multiple things, sounds electrical but the garage would have the required equipment really to make the best answer for that. Without actually using a scan tool for the transmission, there would just be a whole bunch of speculation that probably wouldn't help. I would just ask them since they worked on it and the problem was not resolved that they at least diagnosis the problem correctly now
Was this
answer
helpful?
Yes
No
Thursday, June 27th, 2013 AT 7:20 PM
Tiny
COORS697
  • MEMBER
Also eng light appears time after time but code at local garage says its oxygen sensor, would that be true?
Was this
answer
helpful?
Yes
No
Friday, July 5th, 2013 AT 9:30 AM
Tiny
SEANGRANT00
  • EXPERT
The Oxygen sensor could be failing, but this also could be something else related to the emissions system. Many people will replace them to find out that it was something else. It's strange that they wouldn't of ran a scan tool on it just to verify the problem. I would move up to the shop manager and express what the problem was and ask why they didn't verify the problem.

Sean
Was this
answer
helpful?
Yes
No
Monday, July 8th, 2013 AT 12:08 PM
Tiny
COORS697
  • MEMBER
Still haven't went garage but notice now that on the trip display if I zero it or reset it and drive very little Kms the display will he more than driven, very very strange.
Was this
answer
helpful?
Yes
No
Thursday, July 18th, 2013 AT 1:51 PM

Please login or register to post a reply.

Recommended Guides