My cooling fans are not working in high speed.

Tiny
FAKHIR
  • 2007 GMC ACADIA

My cooling fans are not working in high speed but working in low speed, when I remove the engine temperature sensor they got work in high speed it means that relays, fuses and fans are good, then what do you suggest to do here?
the radiator get so much hot and the A/C also comes to hot.
when I m driving then every thing is good may due to the fresh air.
please tell me what is wrong with this?

Do you
have the same problem?
Yes
No
Thursday, November 15th, 2012 AT 3:19 PM

3 Replies

Tiny
SAULTJ
  • MEMBER

Fackir: Do you solve your problem yet? I having exactly the same problem with my GMC acadia. Everything looks to be ok, New water pump, New thermostat, spacial GMC coolant, but some themes my car get hot, and I do the same test disconnecting the engine coolant temperature sensor, but some times start both fans in high, but sometimes only the second one.

If you find the solution, please let me know.

Thanks.

Was this
answer
helpful?
Yes
No
Wednesday, January 22nd, 2014 AT 11:47 PM
Tiny
JUNG
  • MEMBER

Dears,
I have the same problem with my Acadia 2009.
Can you please advice how to fix this problem?

Thanks

Was this
answer
helpful?
Yes
No
-1
Saturday, May 16th, 2015 AT 7:48 PM
Tiny
ASIMARSHID786
  • MEMBER

Mr faikr after removing thermostat become the same means radiator hot and ac air hot or with thermostat it comes radiotor hot and ac hot kindly reply

Was this
answer
helpful?
Yes
No
Saturday, June 13th, 2015 AT 5:38 AM

Please login or register to post a reply.

Other Coolant Temperature Sensor CTS Replace/Remove Questions