RECENTLY DEVELOPED AN EXTREMELY ROUGH IDLE

2007 Dodge Charger

Tiny

mcarloswells

December, 27, 2011 AT 10:07 PM

I have a 2007 Dodge Charger 2.7 V6. It recently developed an extremely rough idle. When the engine is cold, the engine seems to run and idle fine. Once the car is warm the whole car shakes at idle. I have replaced the spark plugs thinking that it was a problem.

Changed spark plugs. Cleaned air filter. Seems to have had a slight misfire when idling before this issue. Now entire car shakes when the engine is warm.

FOUND 2374 RELATED QUESTIONS

9 Answers

Tiny

ASEMaster6371

December, 27, 2011 AT 10:25 PM

Check the coil boots for arcing. The coils themselves may be bad. Is the check engine light on?

Roy

Tiny

mcarloswells

December, 27, 2011 AT 10:33 PM

Yes. Check engine light turned on instantly with the rough idle. All boots looked fine except one that looked like a brownish burnt color unlike the other which were gray rubber.

Tiny

ASEMaster6371

December, 27, 2011 AT 10:34 PM

Get the code checked and get back to us.

Roy

Tiny

mcarloswells

December, 27, 2011 AT 10:36 PM

I am working on getting the code checked. Should have a code for you in about an hour. Thanks for the help!

Tiny

mcarloswells

December, 27, 2011 AT 10:52 PM

So I ran a test. It gave me the following code.

P0202 Injector Circuit / Open-Cylinder 2

Tiny

ASEMaster6371

December, 27, 2011 AT 10:55 PM

Ok, you need to check the wiring to the injector, along the intake for any breaks or grounds. You need to ohm out the injector as well. Check for 12 volts at the connector with the key in the on position.

Roy

Tiny

mcarloswells

December, 29, 2011 AT 8:58 PM

So the injector seems to be getting the right amount of voltage to it. However, when I start the engine and unplug the injector in cylinder #2, there is no change to the engine idle. If I unplug, number 4 next to it, the engine idle changes dramatically. Like I said though, #2 seems to be drawing the same amount of voltage as the others. Bad injector?

Tiny

mcarloswells

December, 29, 2011 AT 9:45 PM

Ok, scratch that last one. Injector on cylinder number 2 seems to give the engine a rough idle when unplugged when engine is not up to temp. Once at temp, does not make a difference? Throttle positon sensor?

Tiny

Joseoso1982

November, 1, 2015 AT 6:30 PM

Do you fix the probleme of you charger? I got the same probleme with mi charger to, please let me know how you fix you car, thank you

Please login or register to post a reply.

Vacuum Leak Test and Repair - All Cars
Cylinder Head Valve Job Guide
Fuel Injector Replacement Ford 5.4L V8
Spark Plug and Wire Replacement Ford Mustang