06 Volvo S40 - sputtering and dying

Tiny
06VOLVO
  • MEMBER
  • 2006 VOLVO S40
  • 77,000 MILES
I have a 2006 Volvo S40, the problem is that it sputters when I am driving it like it is not getting fuel and sometimes it dies when I stop in drive (like at a traffic light) Some days it does this and other days it drives fine. I have taken it to 3 shops, including my volvo dealership here and another volvo specialty shop. They cannot find a thing. It is driving fine according to them. They cannot get any diagnostic codes back on anything. They want me to come get it tomorrow but the problem is not solved. Has any one else had this happen before? It has 77K miles and has new spark plugs, tune up etc last summer. It was doing the same thing last summer and the shop installed a new accelerator pedal. That alleviated the problem for almost a year but now it has started again. Please help.
Do you
have the same problem?
Yes
No
Thursday, July 7th, 2011 AT 11:13 PM

3 Replies

Tiny
JIS001
  • EXPERT
What you can do is have the throttle cleaned out first and disconnect the ECM connector to reset adaptations? Another issue you could be having is the fuel pressure sensor could be faulty? When Volvo checked it out, did they do a scan of all the control units? What fault codes were posted? Let me know please?
Was this
answer
helpful?
Yes
No
Friday, July 8th, 2011 AT 7:11 AM
Tiny
06VOLVO
  • MEMBER
Thank you for your response. Apparently the problem the shop is having is getting the problem to manifest so that they can actually see what it is doing. He says they ran all the diagnostics and nothing. There has never been a check engine indicator or anything. One of the shops pulled a code that said "behavior problems" and the other shop pulled a code that said something about cam shaft intake. That shop told me that what they were getting has to do with timing and could just mean a new timing belt (my other guy checked and said the timing belt is fine- car only has 77,000 mi on it)or it could be something else wery costly. My guy checked the cam and said there was no problem there. I will check with the shop about what you mentioned above when they open on monday. In the meantime if any of the additional info I just provided gives you any other ideas please let me know.
Was this
answer
helpful?
Yes
No
Saturday, July 9th, 2011 AT 4:42 PM
Tiny
JIS001
  • EXPERT
Well for the behavior problem you would need the ECM software updated/
Was this
answer
helpful?
Yes
No
Sunday, July 10th, 2011 AT 7:46 AM

Please login or register to post a reply.

Recommended Guides