SPEEDO NOT WORKING + ABS WARNING LIGHT.

2006 Vauxhall Zafira

Tiny

mickdent

July, 9, 2012 AT 4:41 PM

My car is currently recovering from some light front end N/S damage.
After getting it running there is no speedometer at all and the ABS warning light is on.

I have already replaced the hub assembly with the ABS sensor in and that
didn't help much. It's been plugged into the diagnostics and I've been told that the ABS pump is faulty.

Would this faulty pump stop the speedo from working?

And if anyone has any other ideas as to what I could try then I'd appreciate it.

FOUND 2124 RELATED QUESTIONS

5 Answers

Tiny

Wrenchtech

July, 9, 2012 AT 5:02 PM

How would you know which hub was having the problem or whether that was even the issue?
You need to have the ABS codes read and the stored code will tell you where to look for your problem.

Tiny

mickdent

July, 9, 2012 AT 7:40 PM

The only damage to the car was the left hand side so i'd have to assume that it was that hub that was damaged as the wishbone was slightly bent too.

Tiny

mickdent

July, 10, 2012 AT 7:05 PM

I've had a friend look at it who works for audi and knows his electrics, checked all thee wiring and says that there is power going to the ABS pump but it aint running, hence new pump, but I still dont know if this is gonna fix the speedo problem.

Tiny

mickdent

July, 11, 2012 AT 9:15 PM

Got the problem sorted, turns out it was the ABS pump.
Got a one from a local breakers yard, fitted it and bled the brakes. Upon startup, all warning lights went out on the dash and the speedo works fine. Total cost 60.

Tiny

rivermikerat

September, 7, 2012 AT 5:49 PM

Thank you for letting us know what the fix was, mickdent. We appreciate it, and others with the same problem will too.

Thank you for using 2carpros.

Please login or register to post a reply.

ABS Computer Replacement
Code Read Retrieval/Clear Honda Civic
Read Codes Like a Pro
Brake Light Bulb Replacement Mercedes Benz
Code Read Retrieval/Clear - Dodge Stratus