NEED HELP TRYING TO DETERMINE WHY MY CAR IS STILL RUNNING ROUGH

  • Tiny
  • Rob77518
  • 2006 SUZUKI VERONA
  • 56,000 MILES

Hello I have changed out my coil packs that was bad to my car cuz it was running really rough cleared my check engine then it came back on again and it said my oxygen sensor was bad bank 2 sensor 1 so I changed that out but my car is still runnin real roguh was trying to see if u had any suggestions on whats my next step I mean I checked the spark plugs they looked good im just stuck and dont really have the money to take it to a mechanic

Do you
have the same problem?
Yes
No
Friday, September 30th, 2011 AT 2:26 AM

4 Replies

  • Tiny
  • Rivermikerat
  • MEMBER

Check for vacuum leaks. Check for play in the throttle body. Check the EGR. Check the plug wires. With the engine running, pull and replace one wire from the plugs at a time. If pulling a wire causes the engine to run better or worse, replace it.

Was this
answer
helpful?
Yes
No
Friday, September 30th, 2011 AT 2:40 AM
  • Tiny
  • Rob77518
  • MEMBER

My car doesnt have plugs it has coil packs I have changed the 2 that was bad the other 4 was firing egr valce is gooit just sounds really rough whenever u rev up the engine like it hesitates to get up to speed

Was this
answer
helpful?
Yes
No
Friday, September 30th, 2011 AT 2:46 AM
  • Tiny
  • Rob77518
  • MEMBER

But yea thats the only codes that it brought up so im not to sure where to go I have checked the hoses for leaks but found none

Was this
answer
helpful?
Yes
No
Friday, September 30th, 2011 AT 2:51 AM
  • Tiny
  • Rivermikerat
  • MEMBER

The fuel injectors may be clogged, causing a bad spray pattern. Run a good quality fuel system cleaner through the tank. Disconnect the harness from the coil packs individually to see if doing so makes any difference. MAP/MAF sensor could be faulty. O2 sensor. TPS, IAC, EGR.

Was this
answer
helpful?
Yes
No
Friday, September 30th, 2011 AT 3:23 AM

Please login or register to post a reply.

Other Engine Runs Rough Questions