Non working speedometer and odometer

Tiny
ARKCUTIE09
  • MEMBER
  • 2006 NISSAN MAXIMA
  • 3.8L
  • 6 CYL
  • AUTOMATIC
  • 158,493 MILES
Bought a 2006 Nissan maxima 2 weeks ago, the ABS, break, service engine soon, TCS off, and slip lights are all on. The speedometer is not working nor the trip meter (odometer) bought the car with 158493 miles done a 700 mile round trip and hasn't changed a bit. Car runs great, fast, AC works, no other issues rather than needing a transmission fluid change.
Do you
have the same problem?
Yes
No
Monday, October 6th, 2014 AT 9:54 PM

11 Replies

Tiny
SATURNTECH9
  • EXPERT
This sounds like you have an VSS sensor that is out have you tried to change it?

Here is the location. Check out the diagrams (Below). Please let us know what happens.

Cheers
Was this
answer
helpful?
Yes
No
Monday, October 6th, 2014 AT 9:59 PM
Tiny
ARKCUTIE09
  • MEMBER
I have an appointment tomorrow afternoon, but there's nothing I could possibly check myself? Is it hard to change transmission fluid?
Was this
answer
helpful?
Yes
No
Monday, October 6th, 2014 AT 10:03 PM
Tiny
SATURNTECH9
  • EXPERT
If you had a code reader/scan tool you could check the codes. The transmission service you drain the fluid drop the transmission fluid clean the pan and change the filter its not that bad.
Was this
answer
helpful?
Yes
No
Monday, October 6th, 2014 AT 10:07 PM
Tiny
ARKCUTIE09
  • MEMBER
OK I will send you all the codes tomorrow afternoon
Was this
answer
helpful?
Yes
No
Monday, October 6th, 2014 AT 10:09 PM
Tiny
SATURNTECH9
  • EXPERT
Ok sounds good.
Was this
answer
helpful?
Yes
No
Monday, October 6th, 2014 AT 10:23 PM
Tiny
ARKCUTIE09
  • MEMBER
I had the diagnostics ran yesterday and they said it pulled up no codes on any of it so its something else, like I told them the car runs perfect except those things. And I can't use cruise control because of the speedometer and I don't know the correct miles on it for oil changes
Was this
answer
helpful?
Yes
No
+1
Wednesday, October 8th, 2014 AT 5:37 AM
Tiny
SATURNTECH9
  • EXPERT
That makes no sense with all those lights coming service engine soon traction etc there should be codes in a few computers. Even if the cluster was out if the service engine soon light should mean there is a code as well as the other lights.I would see if there is a speed signal showing while driving on a scan tools live data.I know you dont have a scan tool just letting you know what needs to be done.
Was this
answer
helpful?
Yes
No
Wednesday, October 8th, 2014 AT 6:17 PM
Tiny
ARKCUTIE09
  • MEMBER
How can I do that? I use my GPS for my speed
Was this
answer
helpful?
Yes
No
Wednesday, October 8th, 2014 AT 6:52 PM
Tiny
SATURNTECH9
  • EXPERT
You would need a scan tool that can read live data like vehicle speed that's the world we live in to diagnose the newer cars.
Was this
answer
helpful?
Yes
No
Wednesday, October 8th, 2014 AT 7:06 PM
Tiny
ARKCUTIE09
  • MEMBER
Well I took it to the Nissan dealership and had a transmission fluid change they also pulled a few codes as far as miscommunication between the transmission and the computer but they did a fluid change and my transmission don't work at all now if the car is all the way cold it will catch gear but after driving 2-3 minutes it starts not wanting to catch again and then I turned the car off for about 5 minutes and it caught gear like nothing was wrong for 2-3 minutes of driving then it stopped catching gear again. So I took it back and they replaced the VSS like you said now everything works great. I wish I listened to you in the first place. I love this site.
Was this
answer
helpful?
Yes
No
Friday, October 10th, 2014 AT 8:39 PM
Tiny
SATURNTECH9
  • EXPERT
Glad you could get it fixed, that kind of problem can be tough. Please use 2CarPros anytime we are here to help

Cheers
Was this
answer
helpful?
Yes
No
Friday, October 10th, 2014 AT 10:54 PM

Please login or register to post a reply.

Recommended Guides