2006 Mercedes Benz S350 the car die after 35min

Tiny
CHANAVAZ
  • MEMBER
  • 2006 MERCEDES BENZ S350
  • V6
  • AUTOMATIC
  • 40,000 MILES
The car engine switch off automatically after 35minutes for first time then have to wait around 5 minutes for the engine give start again, and second time is quickly to switch off automatically its around 10 minutes, I already send for diagnostic but its showing many errors, like abs, esp, gear box, battery current, sensors, crank shaft, many errors and all eraseble errors.I already change the battery, crank shaft, and fuel pump but the problem its still in the car. For the third time when engine switch off the km going up without car driving the speed increasing, without the engine working only the ignition on.
thank you
Do you
have the same problem?
Yes
No
Thursday, March 27th, 2014 AT 12:55 AM

6 Replies

Tiny
KNOWLEDGE IS POWER
  • EXPERT
You have a battery current code and a new battery. I'd check the charging system next. No less than 13.5 volts with ALL the loads on at idle. All those other codes were probably set by low voltage. The computer doesn't like that
Was this
answer
helpful?
Yes
No
-1
Thursday, March 27th, 2014 AT 4:27 AM
Tiny
CHANAVAZ
  • MEMBER
Hi, how are you? The car has two battery one is in front and other is on back, the front battery when engine is switch off has 12.5 voltage and when engine is on is going to 13.8v. And on back side batterry when engine is off is 11.8 and when engine is running is going to 13.5v. I already change two time battery and one time the car drives for long time but then after some days the air conditioner stop working.
Thanks
Was this
answer
helpful?
Yes
No
Thursday, March 27th, 2014 AT 5:36 AM
Tiny
KNOWLEDGE IS POWER
  • EXPERT
I'm fine thanks. And you? The rear battery at 11.8 concerns me as it sounds like the charging system is working. Was that voltage with all the lights and ac and everything on? Open the doors so the interior lights come on then check the voltage. Let it run like this for a while and check it again. If it's still 13.5 then the alternator is working and the rear battery should show 12.5 or 12.6 volts. It shouldn't ever be below 12 volts. They are fully charged at 12.6 volts
Was this
answer
helpful?
Yes
No
Thursday, March 27th, 2014 AT 6:43 AM
Tiny
CHANAVAZ
  • MEMBER
Hello I check the battery after all the lamps switch on when the engine is running its 13.8v, and after I switch off the engine its giving 12.2v. Another thing wich I saw yesterday is when the car was stopped the engine running the engine doesn t switch off, but when I drive for 15minutes the engine go off, it can be a problem of gear box or any sensor of gear box doing this? Because when I drive the engine cut the current. And yesterday without driving the engine was working for 2 hours.
Thanks
Was this
answer
helpful?
Yes
No
Friday, March 28th, 2014 AT 12:59 AM
Tiny
CHANAVAZ
  • MEMBER
And another thing is the air conditioner ( a/c) sometime is working I mean the ventilating air the air sometime is coming and sometime stop.
Thanks
Was this
answer
helpful?
Yes
No
Friday, March 28th, 2014 AT 1:24 AM
Tiny
KNOWLEDGE IS POWER
  • EXPERT
If the engine only dies when you drive the car then it is possible that the transmission could be playing a role. Put the car in drive and set the parking brake and see if it stalls then too. You ac fan motor sounds like it's dying. The brushes are probably worn. To be sure you'd need to make sure it's getting power and ground at the motor plug when the motor isn't running. Then you know the motor is the problem. If the power isn't there then it's most likely a control or wiring issue
Was this
answer
helpful?
Yes
No
Saturday, March 29th, 2014 AT 1:08 AM

Please login or register to post a reply.

Recommended Guides