Transmission problems?

Tiny
MALLENMIFAN
  • MEMBER
  • 2006 KIA SORENTO
  • 6 CYL
  • 4WD
  • AUTOMATIC
  • 70,000 MILES
Went to park my car and could not shift into park or neutral with out hearing a very loud whinning/grinding noise. I shifted into reverse, (reverse and drive were fine), turned the key off, then shifted into park and removed key. Next day was fine? Temp was about 17 degree and car was only partially warmed up. Any Ideas?
Do you
have the same problem?
Yes
No
Sunday, January 9th, 2011 AT 2:40 AM

4 Replies

Tiny
DOCFIXIT
  • EXPERT
What is status now? Sounds like direct clutch pack did not release
Was this
answer
helpful?
Yes
No
Monday, January 10th, 2011 AT 4:21 PM
Tiny
MALLENMIFAN
  • MEMBER
It has not happpened since. Been working good since. Just a freak glitch or something I should worry about?
Was this
answer
helpful?
Yes
No
Monday, January 10th, 2011 AT 8:15 PM
Tiny
DOCFIXIT
  • EXPERT
Could be a random event was trans fluid at 60K?
Was this
answer
helpful?
Yes
No
Tuesday, January 11th, 2011 AT 5:14 PM
Tiny
MALLENMIFAN
  • MEMBER
I believe the transmission fluid was changed about 15k miles ago. Had work done on my torqe converter. Dealership had provided wrong sized spare tire which caused a problem, they fixed the existing one but did not replace it. I am assuming that would require a fluid change. Have not had any other problems since then, until now.
Was this
answer
helpful?
Yes
No
Wednesday, January 12th, 2011 AT 4:01 AM

Please login or register to post a reply.

Recommended Guides